1

On my Windows 10 laptop from the browser (Chrome, Firefox, Waterfox, Edge) trying to access internet sites reports that it can't connect after a while, but ping works. Accessing local servers is fine. Accessing sites through an explicit local proxy in Waterfox also works.

After a reboot the browsers work for a bit, but then fail.

putty telnet seems to work fine.

I've already tried steps from:

Ping works fine, but no Internet connection in browser

netsh winsock reset catalog
netsh int ip reset reset.log
netsh advfirewall reset
ipconfig /flushdns
ipconfig /registerdns
route /f

I've done a wireshark and it shows that TCP connections are getting reset (RST packets from the machine as far as I can tell).

The machine has Sophos Anti-virus installed. MS Office also, but not much else.

EDIT: I have now tried:

  • Disabled the firewall - the problem still occurs.
  • Tried Opera browser as well
  • Tried wget from powershell - also reports the connection being reset, at the same time that the browsers are not working
  • Tried Privoxy - also not working when browsers direct aren't working.
  • Removed Sophos entirely in case that was causing the problem.
  • Done a malware scan with Sophos Virus Removal Tool, which found nothing.
  • Updated the wireless driver for the built-in wireless adapter.
  • Tried a USB wireless driver.
  • Tried a wired connection, which seemed to work, but maybe we didn't leave it long enough.
  • Flushing the caches of Chrome, which appeared to work for a while.

Any ideas for how to get browsing working reliably?

  • Have you tried updating your Sophos and running it? The only time I've had browsers not work when the internet was working for other apps was when there was a virus/malware that wanted to prevent the user from downloading a tool to remove it. That used to be a fairly common "virus removal tool prevention" technique a few years back. You might also want to check your Internet Options and check the proxy settings. – computercarguy Dec 4 '17 at 22:08
  • 1
    I would try disabling your firewall temporarily and flushing or bypassing your browsers' caches when the problem occurs, to see if this allows connections. if it does, you will have a better idea of where to look for a cause. – AFH Dec 4 '17 at 22:13
  • We have now resolved the problem with a windows reset (keeping user data) – Douglas Leeder Dec 23 '17 at 19:56
  • Looking back - the issue happened again, and was again fixed with a Windows Reset. We think the most likely candidate was connecting her phone via USB to the computer. Maybe setting some kind of alternative network route? – Douglas Leeder Jun 4 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.