6

So basically, from time to time, copy/paste between by host (Windows 10 Pro) and my RDP connected host - stops working.

This is not a case of "remember to enable Clipboard in your RDP settings". It works - most of the time - but sometimes, for reasons I cannot figure out, it stops working.

I've searched around, and the only seemingly valid tips I've found involve resetting the RDPCLIP.EXE. Via Task Manager or Command Line. Like so:

Taskkill.exe /im rdpclip.exe
rdpclip.exe

Source: Copy and Paste is not working on my Remote Desktop Connection… what’s wrong?

Problem is, there is no such thing as rdpclip.exe on Windows 10. So what would be my alternative way of achieving this?

1 Answer 1

4

Try launching rdpclip.exe using the command

C:\Windows\System32\rdpclip.exe

I checked on my Windows 10, it is present at given location. Use sfc /SCANNOW if you think it could be missing due to damaged Windows installation.

2
  • 1
    Right you are. It wasn't listed in my process list, so I assumed Windows 10 had something different here. I tried starting it and it made no difference. But then I tried reconnecting via RDP (which I had tried before, without any change) - and NOW copy/paste works again. Thank you :-) Dec 5, 2017 at 12:58
  • i have similar problem with rdp clipboard, tell me please where do you restart RDPclip.exe on host on guest or both?
    – Yurij
    Aug 26, 2019 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.