2

I have a Windows 7 workstation at my office that has all my VPN connections set up on it. When I need to connect to a client's VPN, I remote into that machine and then connect and do what I need to do.

One of the VPN connections is Cisco AnyConnect. I have a number of different clients that I connect to with AnyConnect. Most of them work fine. But the other day I connected to a new client on AnyConnect which had connecting from an RDP turned off. Okay, whatever. That's fine. It's their policy, no issue with that.

The problem is ever since attempting to connect to that one, now I cannot connect to any of the others anymore either. I've confirmed nothing changed on the other clients. However now when I attempt to connect to any of them, I always get this message:

enter image description here

Somehow it seems like attempting to connect to the client which had RDP connections turned off has changed some setting on my client that has completely disabled it for all connections. I need to re-enable this so that I can connect to the other clients.

I've already tried uninstalling AnyConnect, reinstalling it and then reconnecting to other clients, but I still get this error. I've looked in the registry under HKCU\Software and HKLM\Software for Cisco stuff, but didn't see anything obvious.

How can I re-enable RDP connecting in the AnyConnect client so that it will work again for the connections where it is enabled?

  • You'll have to speak to whomever looks after the Cisco endpoint, as the software gets its settings from the VPN device you are connecting through. There are very few settings in Anyconnent Client, as i'm sure you've noticed. – Stese Dec 5 '17 at 16:01
  • I've checked with both people who manage one of the other ones, and they have assured me nothing has changed. It was only after I connected to the one client with no rdp connections that suddenly i can't do rdp connections to any of them. It literally worked fine right up until I connected to that client. I was on other ones minutes before that. – eidylon Dec 5 '17 at 16:43
  • You spoke to the person who manages the Cisco VPN Endpoint? because that is where the restriction is being applied. It has NOTHING to do with the other VPN's on the system. The Cisco Anyconnect client is being disallowed to connect in a RDP session, due to its own security settings. These settings come from the VPN Endpoint/device. (A Firewall or specific VPN device). – Stese Dec 5 '17 at 16:48
  • Allowing VPN connection for a remote user is strictly a property from VPN profile. If the VPN profile configured for connecting tunnel group restricts VPN for remote user, then AnyConnect service will not allow the connection. So, I recommend to check the VPN profile configured for the slected tunnel group(i.e., authentication group) which can be identified from the AnyConnect logs. – Mahesh Dec 6 '17 at 16:21
1

I'm not sure exactly what happened here.

I contacted Rackspace who is our host/provider for the firewall and VPN. They said they did not see ANY profiles configured for our VPN, so they created one and set it to allow remote connections. All is working again now.

Either it was just bad timing that it somehow got deleted nearly simultaneously with connecting to the other VPN, or maybe by default it allows it, but then when I connected to the other one, its setting for Disallow RDP override my client's default, given that our VPN apparently had no configured profile.

At any rate, when Rackspace created a profile on our VPN, it works again. It remains to be seen if the other VPN will wind up killing it again or not. I'm not giving it a try until I need to!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.