1

When using TextEdit on a mac, I disable various Substitutions and Spelling and Grammar options (e.g., Edit -> Substitutions -> Smart Copy/Paste). But they come back every time I re-open a document. Is there a way to "permanently" disable these options?

1

In Terminal, you could try the following commands according to whether you think they pertain to your needs. Best to do it when TextEdit isn’t running.

defaults write com.apple.TextEdit NSAutomaticCapitalizationEnabled -bool false
defaults write com.apple.TextEdit NSAutomaticDashSubstitutionEnabled -bool false
defaults write com.apple.TextEdit NSAutomaticPeriodSubstitutionEnabled -bool false
defaults write com.apple.TextEdit NSAutomaticQuoteSubstitutionEnabled -bool false
defaults write com.apple.TextEdit NSAutomaticSpellingCorrectionEnabled -bool false
defaults write com.apple.TextEdit NSAutomaticTextCompletionEnabled -bool false

To undo these changes, use the following command, replacing the last term with the appropriate one from the list above that you wish to delete:

defaults delete com.apple.TextEdit NSAutomaticCapitalizationEnabled

I’ve tested it on High Sierra by turning off spelling correction, and then turning it back on. It appears to work. Let’s hope it sticks for you.

  • Thanks! This works and is awesome. But do you know what the command would be for these other few?: Spelling and Grammar > CheckSpellingWhileTyping; Substitutions > Smart Copy/Paste; and Substitutions > TextReplacement – J Woodchuck Dec 7 '17 at 23:38
  • I've done an extensive search and can't find any specific flags for those particular items that I know will work for sure. There are these flags: WebAutomaticSpellingCorrectionEnabled and WebAutomaticTextReplacementEnabled. Although these sound like they're Safari-related, they are global flags so it's possible that turning them off specifically for TextEdit will do what you hope. Of course, it might not. Tell us whether or not they do if you try them out. – CJK Dec 20 '17 at 0:05
  • @JWoodchuck It just occurred to me that you stated you had turned off the preferences by way of Edit > Substitutions > etc. Have you tried turning these options off in TextEdit's main preferences panel (TextEdit > Preferences... or ⌘+,) at the bottom under Options ? – CJK Dec 22 '17 at 7:15
  • I had not tried that. Didn't know that was even an option. And actually, my selections seem to "stick" when I make them that way. Thanks so much! – J Woodchuck Dec 23 '17 at 1:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.