0

I use Spectrum as my ISP and in Filezilla, WinSCP, Putty, MobaXTerm I timeout after about 3-4 minutes and have to reconnect. I have discussed it with my ISP and they swear it is something to do with my computer (or program) but I do not timeout while on other internet lines, Only my main home internet. I have a Motorola router, 300mbps Connection (Usually 230-320) and Spectrum 300 plan.

  • Is the connection idle when it times out? – Appleoddity Dec 6 '17 at 3:04
  • Yes, But for no more than 5 minutes. – NW581 Dec 6 '17 at 20:44
  • That doesn’t matter. You need to enable keepalives in your clients to keep the connection active. Stateful firewalls only keep a connection open for so long. This is not just an issue with Spectrum, this is anywhere, except the time may vary. – Appleoddity Dec 6 '17 at 20:46
  • Yes, But I have friends with Spectrum as well and I never time out with my computer at their house. – NW581 Dec 7 '17 at 18:23
  • i have added a Keepalive to WinSCP to see if that fixes the issue. – NW581 Dec 7 '17 at 18:28
1

I have fixed this issue by doing the following:

In WinSCP:

Site>Edit>Advanced>Enable Keepalives (I did every 30 seconds)

In MobaXTerm:

Settings>Configuration>SSH>Check "Keepalives" box

In FileZilla:

Edit>Settings>Connection>FTP>Enable FTP Keepalives

Thanks to Appleoddity for pointing me in the right direction.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.