2

How can I change the keyboard combination for a non-breaking space (NBSP) from shift+space to something else?

It took a while for me to figure this out: when coding, I run into issues related to using an NBSP accidentally, for example at … = "…. Python for example complains about invalid character in identifier here. That is because I leave Shift pressed while typing all the characters, which makes the spaces be NBSPs.

This happens only on my computer running Manjaro Gnome, in any application (Firefox, Evolution, gedit, Atom, LibreOffice, …). On my other computer running OSX the combination of Shift+Space does not change the regular space character.

According to the NBSP WP entry this is not even the default key combination to generate an NBSP, but I can not remember me changing this anywhere.

So this is why I am asking where this setting could be placed, or how I can change this in Manjaro Gnome 17.1 Hakoila?

1

In the "Keyboard" control panel, "Layout" tab, "Options..." button, there is an entry for "Using space key to input non-breaking space". Shift is the second level, there is a separate option to assign the third level, and fourth level is second+third level.

| improve this answer | |
0

The setting Ignacio talks about is actually placed in Gnome Tweaks at Keyboard and Mouse -> Additional Layout Options > Using space key to input non-breaking space. I set it to 3rd level and hope I will never hit this by accident.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.