5

In Firefox versions v50 to v57 on Windows or Linux, add-ons free, the results displayed of a search on Google is CPU consuming. Easy to see with the task manager showing the CPU. Why do the results of a search on Google eat so much CPU and how can it be prevented?

How much? It depends of the cpu. About 40% on a low Celeron and about 20% on Intel i5. See the screenshots below.

What are your system specs? Any machine, any cpu, on Windows or Linux.

How long do you see that CPU utilization? During the results of the googe search displayed. If we stuck 5 minutes on the results displayed, then 5 minutes cpu utilization.

Try your self, easy to reproduce the phenomena :

Open firefox. Open the task manager on cpu. Search somethning on google and let the results displayed. We can see the cpu utilization increased. Select a result from the results displayed, then cpu utilization decreased.

Below screenshots : before, during the results displayed and after

Windows 10, intel i5, 4 cores: Before - During - After

Linux Ubuntu 14.04, Celeron, 1 core: Before - During - After

5
  • @Seth: topic updated Commented Dec 8, 2017 at 10:35
  • That's one good update! It's actually not that easy to reproduce, at least I'm not seeing this behavior. As it's a continues usage my personal guess would be some kind of malware or program that react so having google open. Personally I'd expect that behavior with some form of coinminer though I wouldn't really expect that on google. You could try to run NoScript in order to prevent script execution to see whenever that helps. If it does, it's likely a script that's loaded by that page.
    – Seth
    Commented Dec 8, 2017 at 10:47
  • Clearly reproducible, FF 58 on Linux Mint, using google.de. Results page burns 25% CPU constantly (4 CPU threads processor, top display). Switch to another tab, everything is fine, switch back to the results page, and it starts heating the room. Switch off javascript (these days only via about:config, it seems) and all is fine. Thanks Google, don't have enough horsepower on your servers anymore, need my little laptop for some cpu cycles? :-)
    – Harald
    Commented Feb 3, 2018 at 11:03
  • Also tried with a clean profile. Same problem.
    – Harald
    Commented Feb 3, 2018 at 21:57
  • @Harald : Finally ! Someone tried to reproduce the phenomena, thanks. Commented Feb 5, 2018 at 10:50

1 Answer 1

3

At least a remedy can be found here:

https://bugzilla.mozilla.org/show_bug.cgi?id=1345468#c13

To paraphrase: the problematic element on the page can be blocked with uBlockOrigin with a custom rule

google.*##g-loading-icon._F9g._y9g

Although the rule looks like it could work for AdBlock Plus, it did not work for me. I switched now to uBO :-)

3
  • Looks like comment 3 wants a performance profile. Can you try recording one and attaching it to the bugzilla issue? Hopefully that'll get them to look into it further.
    – Bob
    Commented Feb 10, 2018 at 13:25
  • Done: perfht.ml/2EzFToU
    – Harald
    Commented Feb 10, 2018 at 13:48
  • This workaround works fine on the machines of the post #1 ! Commented Feb 12, 2018 at 6:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .