0

I created a custom keyboard layout using the layout creator. This is an AZERTY/French layout with Polish characters added:

enter image description here

I don't know what the terminology is, but as you can see, I can select a "keyboard language" by clicking on the "FR" button, and once I'm in French mode, select if I want the default French or custom layout by clicking on the keyboard icon next to it. Let's call that a "sub layout".

My problem: I'm constantly finding that the keyboard has switched back to the French sub-layout from my custom franco-polish one. I'm not sure if this is because I accidentally hit the shortcut (Ctrl+Shift) or because it keeps switching back to the default layout, but it's a constant annoyance. In any case, I don't seem to have a problem with accidentally switching languages (English, French, Russian), just my two french sub-layouts.

Going into my input settings, I can see that my custom franco-polish layout is classified under "French":

enter image description here

As you can see in the right hand window, the default "French" layout is bolded and cannot be deleted/unchecked. I wish I could just get rid of it! I never use it, I only use my custom layout.

My question: Is there any way I can end up with my custom layout as the only sub-layout in the "French" category? I thought I might be able to create an entirely new language category called "French (Custom)" or something and put it in there, but I don't see an option like that in the layout creator.

0

Well, I'm surprised I didn't see this sooner, but the answer is quite simple.

The reason the "French" option appears in bold and can't be removed in the window on the right (in my second screenshot, in the OP) is because it's set as the default input language, in the left-hand window of the same screenshot, the slider menu at the top of the window. I just set that to "French - Franco-Polonais". This unbolded the default French layout in the list to the right, and allowed me to disable it altogether, so that my keyboard layout list now looks like this:

enter image description here

This window can be accessed via Control Panel > Region and Language > Keyboards and Languages > Change keyboards, or by right clicking on the keyboard language button on the taskbar and clicking on "Settings".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.