I have an AMD A10-5800K 3.8Ghz on a Gigabyte GA-F2A88X-D3H board. I've been using it for about 4 years without problem. Yesterday it refused to start the kernel, rebooting on the Loading initrd stage.

At first I thought it could be something related with the hard drives. I have two HD, one with dual Windows/Linux boot and the other, an SSD with only Linux, but all of them failed in the same way.

I made a Fedora usb boot disk and the same happened, reboot in Loading initrd. With that Fedora disk I did a memtest, and everything reported ok.

Finally I found that starting the kernel with maxcpus=1 solved the problem, but of course i just have one of the four available cores.

So, I assume it is a HW question. My doubt now is, what is failing, the motherboard or the processor ? I tend to think that is a mobo problem, but without a solid argument, just I saw lot more mobos failing than processors.

Having no other equipment, what can I do to discard, i.e, a processor problem ? Or would it be safe to discard it already and just buy a new mobo ?

  • I think you mean cores not CPUs because you only have a single CPU installed on that motherboard. The fact it works indicates neither the motherboard nor the CPU is at fault.
    – Ramhound
    Dec 10 '17 at 18:39
  • Correct, I've edited the question. Ops. Then, what could be the problem ? Maybe the power source failing to provide enough power for several cores ?
    – perencia
    Dec 10 '17 at 18:43
  • Have you tried checking your BIOS settings or resetting it? Dec 10 '17 at 18:46
  • 1
    Hard to tell...it could be a bad core (that you disable hen going single-core) or a mobo problem that is mitigated when running with a single core (less frequent access to some hardware), or, as you say a power problem. In decreasing order of failure probability: power supply, mobo, processor....
    – xenoid
    Dec 11 '17 at 8:06
  • 1
    CPU failure without external cause is rare; I suspect a heat problem (fan, paste). If it overheated in the past, that could also have damaged it.
    – dirkt
    Dec 11 '17 at 12:57

I'll post an answer, though I'm not 100% sure if that's correct it can be helpful for someone on the same situation.

Finally I bought another mobo and installed the CPU. The problem persisted on the same terms.

Using the fedora Troubleshooting option of the image I got more details. I transcribe them (omiting addresses)

mce: [Hardware Error]: CPU 1: Machine Check Exception: 4 Bank 0:...
mce: [Hardware Error]: TSC ... ADDR ... MISC ...
mce: [Hardware Error]: PROCESSOR 2:... TIME .... SOCKET 0 APIC 1 microcode ....

Then I found how to do cpu hotplug on Linux.

My solution has been to start the kernel with maxcpus=1 and then create a startup script to bring the third and fourth cores online. If I try to wake up the second core, I end with the same problem, so I guess that core is been damaged (how I cannot tell).

This solution has a pair of drawbacks, but I'm fine with them.

  • Obviosly, I lost one core.
  • I cannot run Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.