I have an Arris NVG599 modem provided by AT&T Uverse (Don't judge me... literally the only broadband provider where I live aside from places like HughesNet). I recently started using the onboard WiFi when my wireless router bit the dust. Plus the Arris has a 5GHz radio where my router didn't.

Anyway, we lost all internet access a little over 2 weeks ago (right before I left for a 2-week business trip). They diagnosed it as a failed router and shipped a new one. Hooked up the new one, still nothing. They sent a tech who didn't touch a thing, and everything mysteriously started working. He was baffled because he saw nothing working then randomly everything started getting access to the web right before his eyes.

All of that may have been irrelevant, but maybe not so I'm including it. While I was out of town, my family was unable to access the web from anything wireless. Everything wireless would connect to the network (and was pingable internally), but got no internet access. Anything wired was fine. I got back into town and found that they had replaced my modem with an older model without a 5GHz radio.

I called Uverse and asked if I could put in the old modem since the replacement was older and wasn't working anyway, thinking the WiFi in the replacement modem was the problem. However, on getting the old modem re-configured after a factory reset, wireless devices still couldn't get to the web.

We set separate SSIDs for the 2.4GHz and 5GHz channels, and I was able to connect to the 5GHz fine with compatible devices. However, devices on the 2.4GHz are still not working. I have another AP in the garage that is also 2.4GHz only, and it is having the same problem. Devices connect, but no internet access. This issue now exists across 3 completely separate devices.

I downloaded a WiFi analyzer app for my phone, and it shows that most of the APs in the range of channels from 6-9. We switched to channel 2 and started getting some results, but it's still really spotty. We got a Kindle and a laptop connected. The Kindle was able to connect to Netflix via the app, but the laptop was getting webpage timeouts. The Chromecast won't connect at all.

May also be worth noting that I have a Corsair Vengeance 2100 wireless headset that uses a 2.4GHz, and it has been having odd "drops" in audio this afternoon as well.

My current theory is that there is something causing interference in the 2.4GHz range. The paranoid in me wants to think it's a jammer, where my more reasonable side is thinking something like oversaturation of the airwaves in my area. But I'm in a somewhat rural community with only about a dozen APs visible if I walk outside, and we only started having this problem within the last 2 weeks or so.

  • There are a massive number of things operating on the 2.4GHz bands. Other wifi networks, cordless phones, bluetooth headsets, non-bluetooth headsets, remote control toys, drones, microwave ovens (operate near that band and a faulty one can "leak"). It could be that your router is also badly situated and is being "shielded" from your devices.
    – Mokubai
    Dec 10 '17 at 21:35

First I have to ask if your provider is aware that your support case is not closed yet? – if not, you could re-open it.

Second, do you see your provider is responsible for this to work because they have WLAN built in in their delivery?

This is my basic action list for complex problems:

  • Define the problem
    • You defined 2.4 GHz WLAN unstable while 5 GHz works; that’s a great description and something we can work with
  • Measure (use diagnostic tools – hardware or software, whatever is necessary)
    • Care for measurement accuracy: Make sure your measuring equipment and methods are 100% correct.
  • Find a workaround/alternative solution
    • You already tried by applying 5 GHz WLAN, but this does not satisfy the affected users because not every device can use 5 GHz
  • Reproduce the problem – this leads more or less directly to the solution
    • Simplify: turn off all WLAN-enabled devices

Oracle released a document for general problem solving steps (OK, it is for Java but the basics steps are the same for any hardware/software related issues) that matches pretty much with my opinion: General Steps to Troubleshoot an Issue (I am not affiliated with Oracle)

What’s most interesting in those documents are those sub-steps:

  • Check for typical causes in the area.

    • my interpretation for you: maybe you can ask your neighbours if they have comparable issues
  • Use tracing

    • my interpretation for you: make sure your measuring equipment and methods are appropriate


Today i talked to the network specialist of trust, asking about spectrum analyzers. He explained that he does not see a big difference between all the freeware stuff and professional devices (for personal use). Further what he did at home was forcing all neighbours networks to other channels than his one. So the conclusio is to just get some spectrum analyzer using google, just make sure you interpret the results really correct.

  • Thanks for the insightful response! I have an active case with my provider, but they're as confused as I am. I have thought about knocking on some neighbors doors and seeing if they're having problems, but not a step I've had an opportunity to execute. I'm not sure what I can do to further narrow down the cause. What other ways can I track down the source? A spectrum analyzer is not at all in my budget, and I don't think tracking down the source interference would be in scope for the provider, would it? The other thing to note is that this started rather suddenly.
    – rtuite
    Dec 10 '17 at 23:08
  • I'd stick to the provider in first case - they have the equipment, you just need to keep to draw in the reins. To get the equipment and methods you need to google a lot or ask some professionals, e.g. i'd ask the networking guys in my company, Also consider that people tend to blame the network for often for problems that are actually not really network related. You could start by simplifying and e.g. eliminate a jammer as problem source by detecting if it can be repaired by restarting the network devices.
    – Harry
    Dec 10 '17 at 23:34
  • Alright, I'll pursue those avenues and see what I can come up with & followup here if I ever get answers. Thanks for the input!
    – rtuite
    Dec 10 '17 at 23:56
  • This doesn't really provide an answer to the question. Answers are expected to identify the solution, not just what questions need to be answered to identify the solution. Fortunately you have enough rep to use the comments to get clarification from the author, which should be done to ask questions about the OP. Dec 11 '17 at 1:41
  • 1
    @Scott Touché... Dec 11 '17 at 16:23

I spent the day reading and sorting out what I did and didn't know about WiFi interference, and I also reached back out to AT&T and was routed to their "premium care" team who also provided some guidance & information, notably that they "recently pushed out a firmware update" and hinted that I wasn't the only one calling about this issue.

I will start by saying nothing about the physical configuration or location of devices has changed prior to the start of this issue, falsely leading me to believe that couldn't be the problem. My modem/WiFi router has been in the horizontal position on a metal network rack shelf for several years. However, as I noted earlier, a firmware update happened which likely caused a shift in the behavior of the router. I haven't got the qualifications or education to truly explain how this can (or can't) happen. I have attempted to find a reference to quantify this one way or the other but I'm coming up empty, though I'd be happy for any education on this matter.

Here is the sequence of steps I took to resolve this issue:

  • Unplugged the WRT54G2 that is set up as an access point & switch only that serves as the connection in the garage
  • Unplugged the TrendNet TEG-S80g 8 port desktop gigabit switch on my desk
  • Unplugged the Netgear JGS516 16 port gigabit switch on the network rack (to which both the WRT54G2 and TEG-S80g connect)
  • Unplugged the Arris NVG599 (to which the JGS516 is connected.)
  • Stood the Arris NVG599 upright on a plastic surface (as opposed to laying down on metal)
  • Plugged the Arris NVG599 back in
  • Tested wireless on both 5 GHz and 2.4 GHz radios was functioning normally
  • Plugged the JGS516 back in
  • Tested wireless again
  • Plugged the TEG-S80g and WRT54G2 back in
  • Tested wireless connections again on both radios of the NVG599 as well as the WRT54G2.

So, basically, unplugging all network devices from the furthest out in the network tree (in my case, the TEG-S80g and WRT54G2) and working back to the modem, then powering them back on in reverse order combined with moving the modem to an upright position appears to have resolved this. The Chromecast, Kindle, and other 2.4 GHz devices are connecting normally now.

I do see the flaw in my process because I can't pinpoint whether it was the network device reset (which I had done, but not in exactly that order) or physically moving the modem. If I were to guess, I would say that the latter had more to do with the resolution than the former.

In any case, thanks to those who responded and got me thinking in the right direction!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.