I have a Comtrend 5220 that provides connectivity to my DSL service. There is a USB port on it and it has set-up options for ENABLE UPnP and ENABLE DLNA. The DLNA section has one configuration option: Media Library Path with the dialog box having pre-filled: /mnt

The question is -- how to I utilize this as a DLNA library (source of music) for DLNA/UPnP clients?

I enabled both options and I changed the setting for library path to /mnt/music. I put a small directory tree of audio files on a USB thumb driver and stuck it in the USB port on the router. First I tried installing BubbleUPnP on a Kindle and looking for the library. No luck but I wasn't sure that if I should be able to see it. I ran windows media player on a Win7 PC and I didn't find the router in Other Libraries section. I installed BubbleUPnP Server on the same PC and it and Media Player both have what might be each other in the Libraries section -- but nothing from the router. The manual is a nothing but a hard copy of the set-up screens.

I don't know enough about how things are supposed to work to even describe the problem further.

  • It should be as simple as set it, forget it and just use it. Note: /mnt is a typical Linux system folder where additional partitions are mounted. Perhaps not a good idea to change it and no need to except for special configurations. Try resetting to the default, reboot the router and search for it from your other devices, with Bubble or any other DLNA/UPnP supporting software.
    – user772515
    Dec 11 '17 at 0:20
  • @MichaelBay - thanks, that's a good idea. I have tried the default /mnt and /mnt/music and "music" with no change with respect to what shows up as a library on Media Player or BubbleUPnP server. It will not accept a blank field. Also it does not show up as a network item in Windows Explorer. With no configuration options other than media library path and no other documentation I am suspecting this is not a functioning feature of this router.
    – Arbalest
    Dec 11 '17 at 19:33
  • Fun fact - I emailed support at Comtrend (the maker of this router) and asked if this feature even works and if there is any documentation on it. They replied that they only sell these to ISPs therefore it is policy to not support it (apparently including answering questions) because it might impact my DSL service! True, the ISP did send this with their installation package.
    – Arbalest
    Dec 12 '17 at 0:04

Someone at AudioKarma.org had info that solved the problem. Posting it here in case someone comes across this same problem later.

The router has a menu item for "Storage Services". From there I could see that my external hard drive was called usb1_5. So, going back the DLNA menu and setting the library path to /mnt/usb1_5 solved the problem.

This is not in the manual and Comtrend refused to answer questions about this since they sell the router to ISPs. Never mind the fact that the ISP sold the router to me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.