0

Recently I installed Pandoc and added its install directory to my system PATH. But I found that I can execute the program only in the system cmd, not in cmder.

I reinstalled the cmder program and the pandoc command can be executed in cmder miraculously. Today, I can not execute the command in cmder again (still can execute the command in cmd), which is weird.

I have read some cmder issue, e.g., issue #443 and issue #792, which are related to mysql. In my case, there is no & character in the Pandoc path, the full path is C:\Users\east\AppData\Local\Pandoc.

If I directly add the Pandoc path in cmder console, set PATH=%PATH%;C:\Users\east\AppData\Local\Pandoc; I can also execute the pandoc command.

Any idea what is the problem?

  • You should check the PATH variable of course. Did you execute set PATH in cmder? Did you try where pandoc? At last, run Process Explorer and check the PATH in the parent processes of your consoles. More reading: conemu.github.io/en/WindowsEnvironment.html – Maximus Dec 12 '17 at 13:25
  • I have checked the outputs of echo %PATH% in both cmd and cmder: output of former contains the path to pandoc executable while output of latter does not. I use set PATH in cmder. where pandoc shows C:\Users\east\AppData\Local\Pandoc\pandoc.exe in cmd and can not find the file in cmder. – jdhao Dec 12 '17 at 14:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.