1

I try a seemingly simple thing: SFTP access (read/write/everything) for the users on my Ubuntu system, but the FTP access should be limited to a subfolder in their home directory.

Now I tried 2 things:

Using vsftpd: But I cannot set the chroot as writeable. Giving me an error: 500 OOPS: vsftpd: refusing to run with writable root inside chroot()

Using mysecureshell: The Home parameter doesn't seem to work, I always end up in the home folder of the user.

What is the best way to accomplish this? How are all those shared hosting companies doing it?

1

/etc/vsftpd.conf:

allow_writeable_chroot=YES
  • This works indeed. How could I miss this? Thanks a lot. – Mathias Maes Dec 12 '17 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.