2

I'm trying to use ncat to connect between virtual windows7 and linux machines.

On linux:

ncat -vnl 4444 --ssl

On windows:

ncat -v 10.10.14.2 4444 --ssl

And when I try to connect from the client I get this error:

Ncat: Failed SSL connection from 10.10.14.2: error:1417D102:SSL routines:
tls_process_client_hello:unsupported protocol

Things I tried that did not work:

  • Adding extra parameters --ssl-cert test-cert.pem --ssl-key test-key.pem
  • Trying the other way around(linux client, windows server) I also googled a lot but, but I couldnt find a real solution, its all what might be wrong.

I can make this work using openssl s_client. But I need to use ncat, how can I solve this problem?

migrated from security.stackexchange.com Dec 13 '17 at 10:37

This question came from our site for information security professionals.

  • what version is the ncat on windows? try getting an ncat of the same version as the linux one. – ztk Dec 8 '17 at 18:28
5

The problem is that the Linux ncat server will only use TLS1.2 for SSL connections. The Windows ncat is not using TLS1.2. This causes the unsupported protocol error.

I can replicate this issue using ncat version 7.60 on linux and connecting to it with openssl s_client using different protocol options. ncat 7.60 only uses tls1.2 for ssl connections.

To make this work using ncat, install the same version of ncat on both systems.

  • s_client is one option, changing ncat versions so that they match is another. – ztk Dec 8 '17 at 18:40
  • changing versions is not possible – Spring Dec 8 '17 at 18:49
  • @Spring Well, this answer explains that the versions are incompatible. If changing versions is not an option, you're out of luck. Is there a particular reason why you can't change the setup? – Arminius Dec 8 '17 at 19:48
  • @Arminius that's pentest virtual lab environment, not recommended to update/downgrade any software – Spring Dec 8 '17 at 21:28
0

As it seems that you are coming from PWK, check out Errata on their forum.

From their forum it seems that openssl s_client is acceptable, at least until this issue gets resolved on windows7 virtual machine.

In case you really need to use ncat, upgrade to up-to date version should help.

  • "I can make this work using openssl s_client. But I need to use ncat, how can I solve this problem?" Can you clarify how your answer addresses the question? It would help to flesh out the "how", and add a link for your reference. – fixer1234 Jun 26 '18 at 20:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.