1

I am trying to boot the current Fedora 27 Live image from USB on a newly bought Trekstore Primebook C11 to determine if the hardware works with Linux.

Unfortunately, I cannot even get into the boot menu of the Live image. Instead, the USB blinks its access light for a short time, an empty black screen with static (non-blinking) cursor appears and then nothing happens for as long as waited so far (tried up to 1h).

I am not sure how to diagnose whats wrong.

What I have tried so far:

  • verify the Live USB works by using it with another computer
  • verify the CPU supports 64bit architecture
  • disable trusted computing and secure boot

My collection of USB flashdrives always gave me a headache when trying to make them bootable but since the one I am using boots with another computer, I think that should not be the problem.

After having found the boot drive selection menu in the "Save & Exit" Panel of the BIOS, I could see that the drive is detected in UEFI mode in two different ways:

  • UEFI: USB DISK 2.0 PMAP
  • UEFI: USB DISK 2.0 PMAP, Partition 1

Both options result in the black screen as described above. There is no option for legacy boot. However, I found the option "Legacy USB Support" which is enabled and whose help text says:

[...] DISABLE option will keep USB devices available only for EFI applications.

Which sounds to me like the enabled state should result in the device being available for non EFI boot as well.

So how do I find out what is going wrong?

EDIT I tried two other Live systems (Knoppix and Antergos) and both booted fine. The only difference I could see, was that the latter contained a partition named EFI while Fedora only offered two "Anaconda" partitions additionally to the system partition. Anyways, the other two livesystems showed that neither touchscreen nor touchpad are supported yet, so this computer will have to wait.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.