7

For a good month or so now Google Chrome has been starting up and reloading my previous session whenever my computer boots up. I don't even have to log on for it to restart as sometimes I can hear videos from the night before, well before I log on.

I've tried the following methods and none have yielded any result:

  • I checked the startup folder in appdata (finding it via shell:startup in run)
  • I tried to check the start-up tab under task manager. No mention of Chrome there.
  • I looked in Chrome's settings to see if there were any options, none of the options I have on would make it start when my computer starts.
  • I've even looked in the registry, under Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run to no avail. There's no value for chrome there.

I'm absolutely stumped. Virus checks have returned 0 threats, there's no indication that another program could be causing this (though I haven't actually confirmed this I can't think of anything else I run causing this issue at all, let alone at startup).

If anyone can shed some light on this, I'd be very appreciative.

EDIT: I've now even just ran autoruns, I've disabled anything to do with Google, not even just chrome and now I'm going to test. Well there's an interesting twist. I've now noticed that Chrome is opening only when left open, which is weird.

Thanks.

1
  • Before you shutdown your system be sure you close Chrome
    – Ramhound
    Dec 14, 2017 at 23:00

2 Answers 2

2

The Fall Creators Update brought some considerable changes. These updates don’t radically change Windows 10, but they do make modifications around the operating system that you’ll notice.

One of these is Windows’s new ability to re-open programs after you reboot. In prior versions, Windows would start you with a blank slate (aside from startup programs). Now, Windows tries to open the apps you had running when you last shut down.

How to Stop Windows 10 From Reopening Last Open Apps on Startup

Press Windows key + D to hide all windows and show the desktop. Then, press Alt + F4 to show the shutdown dialog. Select Shut down from the list and click OK to confirm.

1
  • Are you sure this is new? There are SOME programs that even Windows 7 faithfully restores after restarting, notably Windows Explorer, if I'm not mistaken.
    – Milind R
    Jan 11, 2018 at 18:16
2

Note that even closing all the windows, there is still a Chrome process hanging in background for the Crashpad Handler. Given that it's started using the same executable file chrome.exe, it seems Windows is calling that executable after rebooting.

With your edit to autoruns, you probably disabled the background process for Crashpad Handler, so chrome.exe restarts only when there was some window opened before the boot.

Not the answer you're looking for? Browse other questions tagged or ask your own question.