0

After the latest Windows 10 update, the procedure described in Conclusively stop wake timers from waking Windows 10 desktop no longer works. When attempting to save changes to the reboot task conditions, the user is asked to supply a password for account S-1-5-18, which is unknown. Taking ownership of the "reboot" file doesn't help. Can someone please supply an updated procedure? Thanks.

4
  • S-1-5-18 is the SECURITY_LOCAL_SYSTEM_RID. msdn.microsoft.com/en-us/library/windows/desktop/… so its the role that NT Authority\System belongs to. generally a scheduled task requires the account of the user that runs it when it is edited. you can try changing the user the task runs under, to one whose password you know. – Frank Thomas Dec 15 '17 at 4:32
  • I had already tried that and was unable to change the user the task runs under. Sorry, I should have been more specific: Can someone please supply a tested updated procedure? – Loren Meck Dec 15 '17 at 19:50
  • I have confirmed that the linked procedure, actually does work, on Windows 10 Version 1709. – Ramhound Dec 19 '17 at 13:24
  • Yes, it worked for me on that version also. It appeared to stop working after Windows installed updates for KB4058043 and KB4054517. – Loren Meck Dec 20 '17 at 9:02
3

S-1-5-18 is the Local System account so it is not sufficient to be Admin to change taskschd for reboot for UpdateOrchestrator.

You can solve it by running as local system using tools like PsExec from SysInternals. Download sysinternals PSTools and run this command in an elevated command prompt (as administrator) to launch Task Scheduler: psexec -i -d -s mmc taskschd.msc

1
  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Jan 14 '18 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.