1

I've been having problems with the realtek audio drivers for a few days. Last night I removed it as per the instructions in on this post (Keep the Realtek application off my computer in Windows 10).

I would now like to undo this removal. Does anyone know how?

I have currently have no sound and no speakers show up in Playback Devices.

I have tried reinstalling after which "Audio Device on High Definition Audio Bus" shows up in the device manager, but I nothing else changes,

I have tried updating the driver in Device Manager. Windows recognises it as Realtek, but fails to update the drivers stating that Access is Denied.

enter image description here

I have tried to System Restore, but this failed stating that it couldn't restore the Realtek audio drivers

7
  • I have, the installer runs as intended and install the drivers, but I have no sound, the speaker doesn't show up in playback devices and when I check device manager the Realtek drivers don't show up there either
    – Sinjon42
    Dec 15 '17 at 10:34
  • All I can find in device manager is "Audio Device on High Definition Audio Bus" under Other Devices and if I try to update it Windows encounters a problem and says that "Access is denied." i.imgur.com/LCo2lmq.png
    – Sinjon42
    Dec 15 '17 at 10:39
  • 1
    Now let's remove our comments as they're not useful for others. +1 good quesiton
    – Dave
    Dec 15 '17 at 10:46
  • I have tried to System Restore, but this failed stating that it couldn't restore the Realtek audio drivers.
    – Sinjon42
    Dec 15 '17 at 10:51
  • There is an option in method 5 here but I can't verify it won't cause other issues troubleshooter.xyz/wiki/…
    – Dave
    Dec 15 '17 at 10:51
1

Just encountered this problem and fixed it. The steps in Keep the Realtek application off my computer in Windows 10 dealt with permissions so we simply need to reverse the issue.

Go to ‪C:\Program Files\Realtek\Audio\HDA\RtkNGUI64 in Windows Explorer and click on Properties. You'll have access to the exact same interface. Goto Security, then Advanced.

If you did what the link did, then your permissions tab here should be completely empty. Click "Add", you're now greeted by a mostly greyed out screen. Don't be intimidated. Click on Select a principal. A window pops up that is titled "Select User or Group", with a blank box under. Type in "SYSTEM", click OK, then give it Full access. Voila!

If you go into device manager you can manually start the installation. A restart will also work now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.