0

The "Network" section in Windows Explorer shows only my Windows 7 machine. I have mapped a drive letter to another PC (running Win 10) on the network using the "net use" command, so it clearly can be accessed. Even F5 while Network is highlighted after mapping the drive does not show the other machine.

What might I do to fix this? (It is obviously not critical, but rather than mapping the drive with "net use" it would be easier to reach it via Explorer.)

Thanks for any help.

  • When a Windows PC connects to a network for the first time, it asks "Do you want to make this device discoverable?" The non-visible machine is probably not discoverable. I can't test it here, but Google around for "make windows 10 discoverable" and give it a try/ – Christopher Hostage Dec 15 '17 at 16:24
  • Did you turn on network discovery? Here is for Win 10, but process is similar on Win 7: dummies.com/computers/operating-systems/windows-10/… – Appleoddity Dec 15 '17 at 16:25
2

Win + R and enter "\\" + hostname, e.g. "\\otherone", that will open the host via SMB inside the file-explorer, then refresh the network again.

  • Where’s your answer? Use “comments” if you need to ask for more info. – Appleoddity Dec 15 '17 at 16:26
  • My answer is that opening it explicitly via FileExplorer (via SMB) should make it register properly .. the other bit is a bit of an afterthought. Please excuse my lacking concentration on a Friday afternoon. :-P – flowtron Dec 15 '17 at 16:28
  • That worked, tho I don't know if it would have worked if the drive had not been mapped already. (I was not prompted for a username and password, because those had already been provided after "net use".) – J.Merrill Dec 15 '17 at 16:50
  • w/o a specific share you'll just see a list of all the shares - except those that have been hidden (with $ sign - e.g. all drives are usually hidden shares "\\otherone\C$" etc). So there are no credentials required to view the list of shares. – flowtron Dec 15 '17 at 16:51
  • @Appleoddity I've edited the answer now - so posterity won't have to suffer as you did. ;-) – flowtron Dec 16 '17 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.