Whenever I get an incoming email in Thunderbird, a box pops up at the corner of my screen saying "...new message from..."

The box sits over the icon to delete the message. I cannot close the box. So, if I want to delete the message, I have to wait until the box closes.

What can I do to stop the message from appearing or to close the box sooner?

2 Answers 2


On newer releases of macOS, the alert configuration is done via System Preferences > Notifications rather than within Thunderbird itself. See the screenshot below - disabling Banners and Alerts should stop the popups from appearing.

Thunderbird Notification preferences

  • Changing from Banners to Alerts did it for me. With Alerts I can click on Close. So now I get the alert but do not have to wait for it to disappear on its own. Thanks.
    – Joel W.
    Dec 20, 2017 at 23:09

I'm running Windows but most probably the settings is in the same place: go to Tools -> Options -> General and disable When new messages arrive... Show an alert. In Customize there's also an option for setting the display period.

Edit: On macOS, this seems to be in Thunderbird -> Preferences -> General -> When new messages arrive uncheck: Show an alert


  • I do not see an option like that on my mac mini. I looked here: Thunderbird Preferences.
    – Joel W.
    Dec 18, 2017 at 16:12
  • Is that Thunderbird 52.5?
    – Zac67
    Dec 18, 2017 at 16:26
  • Yes, version 52.5.0
    – Joel W.
    Dec 18, 2017 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.