1

I just finished updating my Windows 10 installation. However, curiously, when I hover on the Windows Store icon on the start menu bar, I get the following cryptic string:

enter image description here

Clicking on the button momentarily opens the frame of a window but it closes abruptly, without any error messages of any kind.

The same behavior can be observed from other Windows 10-native apps like Pictures, Calendar, and Mail. They are not on pinned on my taskbar (so I can't confirm if they show similar cryptic strings) but when I try to open them from the Start menu, they show only the outline of a frame before closing abruptly.

Of these native apps, Edge alone seems to be working. Other 3rd-party apps (Steam, Firefox, Evince, Sony camera software) seem to be working properly. The manufacturer (Lenovo) apps that came with this laptop work properly too.

In an attempt to get Pictures to load, I tried to open an image from an explorer shell. The native Pictures app is my default program for displaying images. However I get this:

C:\Users\chad\Pictures\crypto.png The app didn't start.

This is the closest to an error message I got. And as you can see, it is not very informative, unfortunately.

I would attempt to reinstall/update these native apps...if only my Windows Store was loading in the first place.

The next logical step would be to rollback the updates. However, I don't use Windows regularly so I tend to install updates in bulk and I have no idea which updates to prod first.

Lastly, I managed to run a Windows 10 diagnostic tool from Microsoft. The results seem to imply that my apps are not loading because I did not tie my Microsoft account to this Windows 10-install. However, for various reasons, I do not want to log-in to my Microsoft account when using my computer. It is ridiculous that I need to sign in with their webservice account just to use a program to view images already in my computer locally! Besides, these apps were working before even without signing-in.

EDIT: I decide to humor Windows and "agree" to sign-in with a Microsoft account in my computer. Which lead me to the following screen:

enter image description here

However, clicking "Add an account" on this window exhibits the same behavior I've been describing above! Looks like I'm on a dead end here.

EDIT (12/17/17): I learned about wsreset.exe but after around 5 minutes of invoking it in an administrator command line, I get the following:

wsreset.exe won't start

Very similar to the error shown when I open am image.

Has anyone else experienced/solved this? Or maybe confirm/debunk my suspicion from the Windows 10 diagnostic tool?

1
  • That's not a cryptic name. The icon shows Windows store installation directory. May be you've to reinstall those UWP apss. See this link.
    – Biswapriyo
    Dec 16, 2017 at 3:46

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.