1

I'm unable to follow a specific link in Google search results. The browser simply gets stuck and does nothing. I have Firefox Quantum 57.0.2 (64 bits) running in safe mode (extensions disabled) on Windows 8.1.

Steps for reproducing the problem:

  1. Search on Google for:

    selenium "Unable to create new service: InternetExplorerDriverService"

  2. Click on link IRC Logs for #selenium | BotBot.me [o__o]

I understand that page has a redirect, but Chrome doesn't have trouble following the link. What I'm experiencing can be seen in this video.

  • The Skip Redirect extension might be of help, if the Google redirect is an issue. – DrMoishe Pippik Dec 17 '17 at 18:01
  • @DrMoishePippik, thank you for your suggestion but it doesn't work. – derloopkat Dec 17 '17 at 19:02
  • Hi guys, was someone else able to reproduce the issue? I also have reported FF DeveloperTools is not working. – derloopkat Dec 17 '17 at 19:02
  • 1
    Yes, exactly the same behavior for me. The most obvious difference is the page that Google loads on the background when clicking this link. It’s the “Redirect Notive” mentioned below. Other results that I checked didn’t come with this page but a simpler one. I also think this is somehow a bug in Firefox. – Daniel B Dec 17 '17 at 19:13
  • Interesting! Using FF 57.0.2, 64-bit, Windows 10.0.16299.125, using the same search, I can navigate to IRC Logs... – DrMoishe Pippik Dec 17 '17 at 22:30
0

The browser simply gets stuck and does nothing

You can use the following workaround:

  1. Copy the link and paste it into a new tab.

  2. You will see a redirect notice:

    enter image description here

  3. Click on the first link and you will be taken to the correct page:

    enter image description here

| improve this answer | |
  • David, thank you for responding but I know I can copy a link. The thing is this shouldn't happen. – derloopkat Dec 17 '17 at 14:02
0

http://smallbusiness.chron.com/turn-firefox-redirect-notice-off-26491.html

Go to your menu on top right, click options, then advanced, then general. Go to accessibility section and turn off Warn Me When Web Sites Try to Redirect or Reload the Page

Also try clearing your cookies and see if that helps the clicking link problem.

| improve this answer | |
  • This is FF Quantum. In tools/options there is only one "advanced" and it's for fonts. Also I'm not getting any notice I want to disable, nothing happens when clicking on a link. Not sure how can this be expected behaviour. – derloopkat Dec 17 '17 at 18:00
  • Changed the answer, sorry about that, for quantum you should directly see options not tools first – ytpillai Dec 17 '17 at 18:09
  • it is exactly the same, going to menu bar/tools/options or just options leads to same page, perhaps the setting you mention was moved to about:config but I don't know – derloopkat Dec 17 '17 at 18:13
  • I have set network.websocket.auto-follow-http-redirects to true but it doesn't make any difference. As mentioned doesn't look normal behaviour when you click on a link and the browser gets stuck. Might be a bug or a problem with my installation. Were you able to reproduce the issue? – derloopkat Dec 17 '17 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.