0

I'm having difficulty connecting my HP desktop and my Lenovo laptop (both running Windows 10 Home 1709) through Homegroup on a wireless connection. Both the Advanced Sharing settings are set to:

Private - Network Discovery on, File/Printer Sharing on, Allow Windows to manage Homegroup settings

Public - Turn on Network Discovery, Turn on File Sharing

All Networks - Turn on sharing so that anyone with network access can read and write files in the Public Folders.

Both networks are set to Private, so there should be nothing wrong with network discovery or sharing. Both computers don't seem to have any issues with the wireless adapters (troubleshooter can't find anything). Both computers have internet access, the firewall settings are the same as they were when I had connectivity before, and my VPN is off on both computers (although that shouldn't matter, either).

Whenever I create a Homegroup on one computer or the other, the computer that has the Homegroup created on it says "Joined," but the other says "Ready to Create." It never says "Ready to Join." It doesn't matter if both computers are on the same wireless network or not (I have two 5G and two 2.4G wireless networks on my router). It also doesn't matter which computer the homegroup originates from.

I have had sharing enabled (through Homegroup) on these two computers before on at least two other occasions, so I don't understand what is happening. I've tried leaving the homegroup and creating a new one (again, on each computer at separate times) with no results. I've tried disabling all the network connectors on both machines and re-enabling them with no results. I've restarted (and completely turned off) both machines, started one up, created a homegroup, and started the other (because the other should find the new homegroup after powering up) with no results. I've restarted and/or turned off both machines, powered both back on, and then created a homegroup on one to see if the other would detect it with no results.

I also read some things about many people having difficulty with Homegroup in Windows 10, and based on some information I found, I went into services.msc and switched "peer network grouping," "peer identity manager," "homegroup listener," and "homegroup provider" to Automatic (instead of Manual), also with no results. The reasoning behind this was supposed to be that once a homegroup was created and quit, it remains as a "ghost" until both computers in question are taken offline. That was supposed to reset things and get rid of the "ghost," but I just keep getting the same results of both computers saying "ready to create" and when one is created, the other still saying "ready to create."

While troubleshooting all of this, I switched to my other 5G wireless network just to see what would happen and got a "ready to join" on the laptop (the homegroup had been created on the desktop). When I entered the password, Windows kept telling me that it was an incorrect password, even though I copy-pasted it and switched passwords 4 times. I reset everything again and now I can't even get that close. I've never had any problems with Homegroup before this, and the computers only had to be on the same network (on the same router with the same default gateway); it souldn't matter if one is on one of the 5G subnets and one is on the other 5G (or one of the 2.4Gs, for that matter). Please help - I'm not doing anything stupid like creating a homegroup on both computers at the same time or having network discovery or file sharing turned off, and I don't have an Ethernet cable to connect the two computers.

  • Extremely stupid question here, but I have to ask, have you tried flushing your dns cache so IP can be reloaded? ipconfig /flushdns as admin. Also can you test interconnectivity with ping. If this succeeds, record the internal IPs when both are on 2.4 and 5 and ensure they are the same subnet, just to be sure that's not the problem. – ytpillai Dec 17 '17 at 16:17
  • Yes, I did, and that didn't do anything. – FredSavage187 Oct 21 '18 at 20:33
  • what were the ping results? – ytpillai Oct 22 '18 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.