17

I am trying to set the "DNS Client" service (also called dnscache) in Windows 10 to DISABLED.

However, when I enter into the services control for Windows the options to manipulate it are all "greyed out".

windows services controls options greyed out

I have also tried to terminate it from the Task Manager, but it throws up an error message saying that it is a matter of "access denied" (I'm running in a test box, as the sole administrative user).

windows task manager error message

I have also attempted to kill it from the command line as such: taskkill /F /PID 3953 Doing this successfully kills the service but only for a split second! It then reappears immediately under a new PID.

How can I set the DNS Client (dnscache) to being disabled?

4
  • 1
    So what is it that you’re actually trying to accomplish? Disabling the Windows DNS resolver isn’t exactly going to solve anything.
    – Daniel B
    Dec 17 '17 at 20:27
  • This service can definitely be stopped. Are you running Task Manager or the services console as administrator? Dec 17 '17 at 20:28
  • I'm having the same issue, nothing I try is able to restart DNS client, I can't even change the logon user. If anybody finds a way to restart network services, plz help!
    – Hikari
    May 21 '20 at 17:47
  • Properties window > dependencies tab > see what it needs to run > stop one of those if possible. Eg stopping "network store interface service" aka nsi will kill dnscache (along with all network capabilities). Legit reason for stopping dnscache is to edit the hosts file, sometimes it refuses to let go & you can't update hosts without killing it first.
    – AFOC
    Jun 3 at 21:34
14

Note that the DNS Client does more than just cache DNS records - it gets them in the first place, so disabling it may limit internet access.

If you still decide to disable it, do this :

  • Use regedit to navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Dnscache,
  • Locate the Start registry key and change its value from 2 (Automatic) to 4 (Disabled)
  • Reboot.

Another method is :

  • Start a Command prompt (cmd) as SYSTEM (psexec -sid cmd.exe)
  • Launch services.msc from it
  • The Startup type drop-down now becomes enabled.
6
  • Thank you very much for this detailed explanation. I have disabled it via the registry editor now. Further: I am testing some custom DNS settings locally so this service was interfering. Dec 17 '17 at 22:34
  • 4
    Damn. Now that I've upgraded to Windows 10 Version 1803, I'm having this problem where I can't stop or restart the "DNS Client" service. Although your answer looked promising, launching services.msc as Admin (or from running .\PsExec64.exe -sid cmd.exe and then services.msc) doesn't seem to help me.
    – Ryan
    Aug 10 '18 at 23:39
  • 2
    @Ryan confirmed. This does not work with recent upgrades to Windows, even when posing as local system via the psexec trick. Jun 24 '19 at 9:25
  • Also noticed that apparently without the DNS Client service (dnscache) the DNS suffix list is no longer shown in ipconfig /all. Not sure whether it still takes effect, though. Jun 24 '19 at 10:09
  • This does not explain why the options are greyed out, and how to un-grey them, though, so: sort of useful, but how does one fix this problem instead of working around it via the registry? Feb 18 '20 at 0:29
3

In addition to harrymc's answer, I found this while searching for the same problem :

Deactivate :

REG add "HKLM\SYSTEM\CurrentControlSet\services\Dnscache" /v Start /t REG_DWORD /d 4 /f

Automatic mode :

REG add "HKLM\SYSTEM\CurrentControlSet\services\Dnscache" /v Start /t REG_DWORD /d 2 /f

Source : https://social.technet.microsoft.com/Forums/windows/en-US/a04284f9-cf27-4f37-82fe-31255f70625f/how-to-disable-windows-10-dns-cache-services?forum=win10itpronetworking

Not the answer you're looking for? Browse other questions tagged or ask your own question.