4

I am trying to use rsync files from my home directory. The error I get is:

rsync: link_stat "/home/xxx/.mozilla/firefox/**/*.sqlite" failed: No such file or directory (2)

I have checked and the file exists, but this error keeps happening.

This is the command I'm using:

HOME_FILES=/home/xxx/

rsync -v --copy-links --recursive --files-from=rsync_files $HOME_FILES $DESTDIR/rs/
2
  • Are you sure in '/home/xxx/.mozilla/firefox/**/*.sqlite' exist? It looks like very strange to use asterix characters in directory. Dec 18, 2017 at 0:11
  • I understood that was the way to specify wildcards in <filename> to rsync when using --files-from=<filename>. for example, /home/xxx/.mozilla/firefox/jb48akxy.default/places.sqlite does exist; when using this instead of the wildcard format, rsync works. ( I want to avoid having to specify the intermediate directory, so I on't need to edit <rsync_files> when I create a new Fx profile.)
    – axd
    Dec 18, 2017 at 13:20

1 Answer 1

0

--files-from parameter does not support regex or wildcards. I think you have to read the man page of rsync:

   --include-from=FILE
          This option is related to the --include option, but it specifies
          a FILE that contains include patterns  (one  per  line).   Blank
          lines  in  the  file  and  lines  starting  with  ’;’ or ’#’ are
          ignored.  If FILE is -, the list  will  be  read  from  standard
          input.
1
  • thanks - but the parameter does not contain wildcards (if literally reads "--include-from=rsync_files", where "rsync_files" is the name of the file); the file it points to does (and those are the "patterns" mentioned in your text)
    – axd
    Dec 18, 2017 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.