0

Windows To Go is not a new concept or tool to me. However, the problem I am having is a new problem.

I have easily installed AND run Windows To Go on a plethora of USB 2.0 and USB 3.0 flash drives with no issues other than maybe a speed loss.

Yesterday I tried installing Windows 10 Enterprise To Go onto my Toshiba Canvio 2TB USB 3.0 external HDD using the following process:

Windows To Go External HDD Installation Process:

  1. Format HDD using NTFS format
  2. Prep .WIM image file for install. My .WIM came from a Windows 10 .ISO to install Windows 10 from scratch.
  3. Go to Control Panel and select Small Icons
  4. Go to the end of the icons list where it says Windows To Go. Click that icon.
  5. My external HDD was listed as something along the lines of Toshiba Canvio II USB 3.0 External Disk. The disk registered as 1.81 TB. I selected that disk free of any errors.
  6. Next screen prompted me for my .WIM. I mounted my Windows 10 x86 .ISO and navigated to the sources folder, and then selected install.WIM
  7. I was then given a list of Windows 10 x86 clean installation images. I selected the only choice that allowed the Windows To Go installation to proceed, and that choice was the Windows 10 Enterprise x86 image.
  8. The Windows To Go installation commenced and completed successfully!
  9. I then restarted my PC and my PC booted to the Windows To Go installation on my USB 3.0 External Toshiba HDD. Cool!
  10. The installation read Getting Ready for a while and eventually restarted and booted back into the Windows loading screen once more.... Which leads to our problem...

Problem Alpha:

I left the drive on the Windows 10 Loading Screen for about three hours the first time... I then restarted the PC and left it on the Windows 10 Loading Screen for about 15 hours next; all night... No luck or furtherance...

The Toshiba External USB 3.0 HDD is lit blue (which means it's in USB 3.0 full speed mode of up to 5 Gbps, or roughly 625MB/s), and no errors have popped up. It just has shown the Windows 10 Loading Screen and has not prompted past that to the usual Windows User and PC Settings Setup portion of the installation for 15 hours....

Q: What has this installation hanging up for so long and how do I fix it?

Any help is much appreciated... And I hope that I have provided enough information to begin troubleshooting. Please ask for anything further I may be missing if it might help to fix this for not only myself but for others as well!

  • USB 3.0 may be the problem. If you haven't injected drivers for your USB 3.0 into the .wim then Windows may not be able to access the drive after it starts loading. Try booting from a USB 2.0 port. You can learn how to inject drivers with dism online. – Appleoddity Dec 19 '17 at 20:52
  • I didn't even think of that. Thank you. But I wouldn't think it would be the driver if it was able to go through that first restart where it does the "Starting Services" and "Getting (Devices) Ready" bit. I've tried a round of letting it work on a 2.0 port and it's still hanging 😡😡😡 – user854695 Dec 19 '17 at 21:59
  • Ok. None the less, it probably is a driver issue. That is what it is doing at that stage. It sounds like you have a running Windows 10 on your hardware, and you are now trying to boot a Windows to Go drive on the same hardware. So, you can export/import the drivers from the working OS to the Windows to Go drive. Or you can download and inject drivers from the manufacturer. You could also install Windows from disc, add all the drivers for that hardware, then sysprep and capture that image as a .wim. Try the export/import method though with dism. – Appleoddity Dec 19 '17 at 22:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.