2

I'm running a Windows 10 guest in KVM under an openSUSE Tumbleweed host. I occasionally need Windows on my laptop for creative applications such as Photoshop and KVM has been great so far. However, when I use my Wacom Intuos Pen and Touch graphics tablet connected through USB, the cursor does not move. Pressure and buttons work as expected and I can still click on things, but I can't see what I'm doing. This happens both with spice USB redirection and with PCI passthrough of the USB controller. The problem only occurs when I use the QXL display mode- however, under a Windows guest this appears to be the only display mode where I can change the resolution.

To clarify- when I use the tablet with a Windows VM and the spice display protocol with the QXL driver, the cursor in the Windows VM does not move as I move the pen. The pen still works as if there is an invisible cursor. This is bad because I can't see where I am about to click, hence rendering applications such as Photoshop unusable. This is not normal behavior and I am wondering how to fix this. This looks similar to RHEL Bug 509358, but that addresses Linux guests running X.

(I use virt-manager to configure my VMs and am, as of yet, unfamiliar with libvirt.)

  • 1
    Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. – Ramhound Dec 21 '17 at 4:24
  • Try to add to the KVM invocation the parameter -device usb-wacom-tablet. – harrymc Dec 23 '17 at 20:33
  • I would try different virtualization software. – HackSlash Dec 29 '17 at 20:49
0

I have been struggling with this as well using a Wacom Intuos Pro. What I will update you on is this problem has been tested with guest Win7 running on a CentOS 7 host. The problem exists in both VirtualBox and in KVM environments. So I purchased Win10 just to eliminate the Windows version. Win10 guest under KVM still has this problem. I haven't tried Xen or VMWare. I can confirm that ALL Wacom features work as designed in the CentOS 7 environment and Linux based art applications. Hence, I believe it is the virtualization that creates this headache.

Discussions with another victim have us thinking this is a graphics issue specific to virtualization. Like it might be a depth issue with the graphics almost as if the Wacom pointer is on the gamma layer instead of in the foreground. This is not going to be an easy fix obviously.

Unfortunately, Adobe Creative Cloud Suite runs in Windows. Otherwise, I would not use that OS. My problems would be solved if Adobe would provide the suite in a Linux version.

0

I had the same issue using a Windows 10 VM under VirtualBox 5.2.20 with Inkscape. The mouse cursor would not move with my Wacom Intuos tablet, but the pressure sensitivity was on. Enabling the mouse trail, making this as small as the slider will allow, shows the cursor position with the tablet pen. To get this, type 'mouse' in the search box, select 'mouse settings' 'additional mouse options' 'pointer options' 'display pointer trails'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy