2

I have Bluetooth headphones, and they were out of battery so I disconnected them. When I tried to reconnect later, they refused, so I tried turning the bluetooth off and on in Windows. When I turned it off, however, the button to turn it back on disappeared:

enter image description here

Furthermore, the Bluetooth icon disappeared from the "hidden icons" in the task bar.

I went to the Start menu and tried using Cortana to turn it back on, I typed "turn on bluetooth" and after a few seconds it said "Bluetooth is connected", and then another second later it says "Bluetooth setting cannot be changed".

What is happening? How can I get my bluetooth toggle back? Should I try uninstalling the bluetooth driver and letting Windows reinstall it upon startup?

EDIT: After restarting my computer, the Bluetooth driver is entirely missing. I will try restarting my computer to see if it reinstalls.

EDIT 2: It did not reinstall.

EDIT 3: I attempted to install Intel's drivers but they did not show up in the driver's list. I then realized that there were "hidden drivers" and indeed, the original bluetooth drivers were hidden for some reason. All of them were up to date, but when I viewed their "properties" they displayed "Currently, this hardware device is not connected to the computer. (Code 45)". Should I uninstall them?

EDIT 4: As per Microsoft's suggestion, I uninstalled the device drivers and attempted to restart to reinstall them. Nope, no reinstall. My bluetooth drivers are just gone forever now.

  • I'm sure millions of people enjoy Bluetooth with Windows. However, I've always found it to be too buggy to use - and gave up after similar headphone trouble in the Vista days. It's probably for the best; wired headphones don't need batteries and so are better for the environment. Save the whale etc. – Sir Adelaide Dec 20 '17 at 5:50
  • Same problem with a dell inspiron 3520. This triggers the problem: superuser.com/questions/1444278/… (but the problem also happens when the BT get confuse with a BT a headset connected to several devices) – JinSnow Jun 3 '19 at 9:55
  • the main thread seems to be here: superuser.com/questions/1153912/… – JinSnow Jun 4 '19 at 15:01
2

EDIT: I just did this a second time because it happened again, and it doesn't fully work. I'm not sure why it worked for me the first time I tried it. Apparently installing the Intel Bluetooth driver and restarting isn't enough. I don't know what to do next.

Solution for anyone who encounters this problem: This worked for me at least.

i.) Go into your device manager (on Windows 10, type "device manager" in the start menu and it should show up):

ii.) Once there, depending on whether or not your Bluetooth device driver had disconnected (for whatever reason), you might need to go to "View" and select "Show Hidden Devices".

iii.) You should be able to see your Bluetooth drivers now (if not, unfortunately I'm not sure what to do, your drivers might already have been uninstalled accidentally and you might just be able to skip to step iv, but no guarantee). Open the "Bluetooth" dropdown menu and uninstall each driver by right clicking it and selecting "uninstall":

iv.) Once all your Bluetooth drivers have been uninstalled, download and install a new Bluetooth driver, such as this one from Intel (make sure you choose the correct version for your system; 32/64-bit). Install it by double-clicking the .exe file you just downloaded and follow the instructions.

iv.i) (Optional) For good measure, restart your system in between uninstalling your Bluetooth drivers, and installing the new ones. Windows might automatically detect that the drivers are missing and reinstall them itself. It didn't do this for me, which is hwy I had to download the drivers manually.

v.) Once the new drivers have been installed, restart your system. For me, when I checked my device drivers after restarting, the newly installed Bluetooth drivers were there, and working properly. Knowing how sporadic Windows 10 seems to be, this could differ on your system, in which case leave a comment explaining the problems you've encountered and I'll be happy to assist (even though I'm not actually an IT guy, I just got lucky in fixing my own problem I suppose).

1

Driver uninstall and restart worked. Toggle switch was missing before, now it's back. Hope others have similar luck.

FYI, mine disappeared after I was forced to reinstall Windows 10.

1

I tried many of the suggested things that are floating around in the support forums but none brought the Bluetooth functionality of the adapter back to life. WLAN worked but Bluetooth didn't. I wasn't able to turn Bluetooth on again since the switch was simply gone and there was also no Bluetooth adapter listed in the device manager. Also enabling hidden devices didn't show up the Bluetooth device.

I tried to uninstall the WLAN drivers, reinstalled the drivers. Removed the driver software for both WLAN and Bluetooth (Intel) but nothing helped. The functionality was simply completely gone as there would be no Bluetooth devices plugged in. I also tried the troubleshooter, did several reboots. Nothing helped.

So I decided to remove my current adapter and exchange it with a old one that was still lying around here (thankfully I didn't sell it). So I booted up with my old adapter and magically Bluetooth functionality was back again. So I turned Bluetooth off, powered the laptop off and replaced the cards again.

After the startup my previously not working card came back to life immediately and works now flawlessly again. I have to say that in my case it seems that a driver update (either WLAN or Bluetooth) broke the Bluetooth functionality of my adapter within Windows 10. It was impossible for me to bring it back to life with just software methods. So maybe this helps someone. It might also be worth a shot to just boot up Windows without the adapter. Power off and put it back in. I haven't tried that but based on my findings this might be a quick fix. Hopefully this saves someone a bit of time because it looks to me that software methods aren't solving the issue at least they didn't for me.

Sorry for copy paste of my answer from another (Microsoft) thread but better having it listed multiple times as it worked for me ;).

Edit: Please also see this answer it might solve the problem by another trick

  • 1
    thanks a lot for sharing this. On what computer did you have this issue? It doesnt seem to be an update issue since I get the same problem by simply turning OFF/ON the NetAdapter (PowerShell). A simple PowerShell command disconnects it, so it should be able to reconnect it. superuser.com/questions/1444278/… – JinSnow Jun 3 '19 at 10:10
  • @JinSnow I'm pretty sure I tried that. But a the other day I found out that there might be a completely different cause. Check this thread were I also wrote an answer superuser.com/questions/1153912/… – thex Jun 4 '19 at 11:37
  • @JinSnow It's an older Dell laptop. In my case it occurred after an update – thex Jun 4 '19 at 11:39
  • I ran into this problem with a laptop Dell Inspiron 3520 (after running Disable NetAdapter * ) – JinSnow Jun 4 '19 at 12:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.