13

I've been experiencing high cpu usage from explorer.exe in Windows 10 Pro since a while ago, and this specific dll function seems to be the culprit. Any idea what it's for? I couldn't find anything about it.

enter image description here

Stack:

enter image description here

After loading symbols:

enter image description here

6
  • Use Windows Performance Toolkit to see the cause. Expand the stack of the Explorer.exe instead of svchost.exe Dec 20, 2017 at 15:03
  • tried that, couldn't find anything with the Ordinal247 function
    – hikari
    Dec 20, 2017 at 16:46
  • Ordinal247 means you haven't loaded debug symbols. if you need help with reading the ETL file, share the etl (compressed as zip via OneDrive) Dec 21, 2017 at 15:54
  • If I load the symbols in Process Explorer the name changes to _WrapperThreadProc
    – hikari
    Dec 21, 2017 at 21:11
  • 1
    Is it just high CPU usage or is it doing any IO? Have had a similar prob in Win7 that I usually don't notice until it looking through my network disks. How much memory is it using? That was another characteristic of my prob. With lower memory, it fill memory; w/higher memory would usually take long enough to fill that I'd notice it; with 10G network card, it would create a network storm -- which sometimes required puling network cord to regain control. MS support eventually told me to upgrd to Win10 as fix. ;^/. Interesting.
    – Astara
    Jun 15, 2019 at 6:48

2 Answers 2

0

As per CPU usage -> explorer.exe / shcore.dll!Ordinal247+0xc0 :

  • Under Control Panel -> Keyboard properties, the Cursor Blink Rate was set on "None";
  • After we changed it to somewhere in the middle -> problem is gone.

Screenshot of the Cursor Blink Rate Config

2
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Toto
    May 24 at 20:52
  • @Toto The essential parts of the answer are already included here! It's not a link-only answer as you accused it of being. May 25 at 10:20
0

Quoting the complete answer provided on CPU usage -> explorer.exe / shcore.dll!Ordinal247+0xc0 :

  • Under Control Panel -> Keyboard properties, the Cursor Blink Rate was set on "None";
  • After we changed it to somewhere in the middle -> problem is gone.
  • Screenshot of FIX
  • I don't know how/why, but this setting was problematic by us.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.