1

On Windows, the keyboard shortcut for permanently deleting files is shift-delete.

When managing files on my computer, I find that often, I press shift-delete and then enter, only to find that the dialog for "Are you sure you want to permanently delete this file?" does not appear fast enough. Instead of the dialog box responding to my enter command, the enter command is processed by File Explorer, and the file opens. Is there any way to make this dialog box appear faster, or to ensure that the dialog box will take over monitoring the keyboard after I press shift-delete?

(And yes, I realize that permanently deleting files often could be risky, but that's a whole other discussion.)

  • 1
    Get a faster computer and disk drive or a slower finger. :) sorry but not sure what other response you’re expecting. – Appleoddity Dec 20 '17 at 19:55
  • I mean, it seems plausible to me that there may be some registry override that could be done to redirect monitoring instantly or make dialog boxes appear instantly. My impressions is that it's not a speed problem exactly, but that Windows wants to take its sweet time with opening the dialog box so I can visually adjust my eyes to it opening. – Graham Dec 20 '17 at 20:01
  • 3
    I understand where you're coming from. I admit I have had the same issue in the past. But, believe it or not, Microsoft isn't in the business of creating slow operating systems. What I'm saying is, I'm not sure why you would think it's not opening up as fast as possible. The operating system is having to process your request, and its taking too long in your opinion. The answer to that is to increase the speed of your computer and disk drive, or change your procedure to wait for the window to appear. It wouldn't make much sense to deliberately make you wait. – Appleoddity Dec 20 '17 at 20:09
  • 1
    I think you've (somewhat inadvertently) helped me to clarify my problem, which is that the animations are getting in the way of useful processing. I'm investigating options for changing the animations currently. – Graham Dec 20 '17 at 20:22
  • 1
    I always "adjust for best performance" when I run Windows VM's. (disable all visual effects) Maybe that can help you? – anders Dec 20 '17 at 20:54
2

Just cancel the delete dialog if you do not want to use it.

Right-click on your Recycle Bin and choose Properties from the menu.

image

In the trash properties dialog, uncheck “Display delete confirmation dialog"

enter image description here

Reference

| improve this answer | |
0

For me, the solution was changing the animation options, specifically the option "Animate windows when minimizing and maximizing":

Performance Options in Windows

To find performance options in Windows 8, go in "Control Panel\System and Security\System", then click the link on the left where it says "Advanced system setting":

Advanced system settings

Within, there's a performance section, with a button labelled "Settings...". Pressing that button will take you to the Performance Options in Windows, where you can change the animation settings.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.