1

I have managed to leave the make default option ticked when using the "open with" option in windows 7. I ideally want this removed so the OS can manage the file type as before. I can't find the menu to remove this anywhere, I'm sure it used to be in the folder options panel in XP.

Thanks

4 Answers 4

2

On the menu bar next to "Organize" in windows explorer, there should be the default action "Open with App" and a drop down box. Choose the drop down box to change what the default program is.

You can also go to the control panel and get the list of all extensions

Control Panel\All Control Panel Items\Default Programs\Set Associations

This is probably pastable into the address bar of your explorer window.

2
  • you can also click on a file of that type. go to open with and choose choose a program and that will re-open that prompt so you can un-select it/change what it opens with.
    – Kravlin
    Apr 6, 2010 at 23:36
  • The Set Associations is what I was looking for but it looks like you can no longer remove a binding, only set it. edit: but after some random guessing it seems I have found the original default. Apr 7, 2010 at 7:50
3
  1. click the “Start” button and select “Control Panel.”
  2. Click “Programs,” click “Default Programs”
  3. Select “Set Default Programs.”
  4. On the left of the screen is a list of all programs installed on your computer.
  5. Click the program you want to associate with a particular file type
  6. Click “Choose Defaults for this program.” Place check marks next to each of the file types you want to associate with the selected program
  7. click the “Save” button.

Source - How to Remove the File Association in Windows 7 | eHow.com

1
  • 1
    It would be nice to include the essential parts of the answer here, and provide the link only for future reference.
    – slhck
    Mar 19, 2012 at 9:14
2

Enter regedit in your Start menu search or in the Run command to open the Registry editor. HKEY_CURRENT_USER \Software \Microsoft \Windows \CurrentVersion \ Explorer \FileExts\ Browse to the file extension you wish to edit, click the white triangle beside it to see the subfolders, and select OpenWithList. notice the names of the programs under the Data column on the right. Right-click the value for the program you don’t want to see in the Open With menu and select Delete. Click Yes at the prompt to confirm that you want to delete this value.

0

Worth noting that even after deleting unwanted program from 'open as' list it would still be available. I just found out this path:

\HKEY_USERS\S-1-5-21-... (this is your user ID)\Software\Classes and find it by name like: pngfile. Just delete whole tree and you'd be fine. I had this problem with Gyazo that didn't uninstall correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .