1

watching and consuming for a long period already, now it's time for my first very own question. ;-)

My Lenovo ThinkPad Yoga 14 (Model 20DM008EGE, Germany) has got an ALPS touch pad. Everything works just fine with Windows 10 (1709) until some point (while working or starting up the system again) when special functions like gestures (pinch & zoom, two-finger scrolling, ...) just stop working. Also the middle mouse button has no function at all any longer. I may still move the pointer, perform clicks by pressing the touch area, left and right mouse buttons. Pressing the lower left edge performs a left click, pressing the lower right edge performs a right click. Also the track point still moves the mouse cursor.

The "ThinkPad UltraNav" tab disappears from Windows' "Mouse Properties" dialog with this phenomenon. It looks to me as if the specialised ALPS driver has somehow stopped or gone into some kind of fall-back mode or compatibility mode. I can re-enable all functions by rebooting the notebook. Shutting down with Fastboot enabled and starting up again does not help. Unfortunately the Windows Event Viewer does not show any related messages (apart from a message quoted below which comes from "DistributedCOM" but does not seem to be related.) The device manager reports "This device is working properly." There is also no way to disable and re-enable it through the device manager. With older Windows 10 versions (up to 1607) the driver used to discard my custom settings from time to time but did not fail completely. Maybe caused by automated updates, I'm not sure.

What I've tried already: Searching the web for similar problem for hours did not unveil any solution. The question by Gerharddc sounds related but resuming from Standby as mentioned does not immediately kill my own touchpad functions: Thinkpad Yoga TouchPad gestures stop working So I uninstalled the Windows 10 default driver (also reported as "ThinkPad UltraNav" in device manager) and installed the most recent one from the Lenovo support site for my model. That is actually an older driver than the one from Windows Update. Also going back to the default Windows driver did not help. In addition, I had to format my C: drive and re-install Windows a couple of times recently but the described behaviour has always shown. By the way: everything works fine under Ubuntu 16.04.3 LTS.

This is pretty annoying and kills productivity somehow. I appreciate any help, even suggesting some touchpad hardware replacement.

Thanks, Kristian

Quote from event viewer, severity Error, source DistributedCOM, event ID 10016:

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID 
{D63B10C5-BB46-4990-A94F-E40B9D520160} (comment: "RuntimeBroker")
 and APPID 
{9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
 to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
  • I had the same problem. Lenovo tried to repair it three times without success, then gave me a full refund under warranty. – Chenmunka Dec 21 '17 at 13:21
  • Unfortunately that's not an option for me, as my device's warranty has expired for years. – Kristian Dec 21 '17 at 15:33
  • I'm currently expecting a replacement touchpad/clickpad said to be made by Synaptics instead of ALPS... curious whether it is compatible or not. I will let you know and include the part number in case anyone else is interested in that solution. – Kristian Jan 4 '18 at 8:18
2

I finally got a solution: hardware replacement. Obviously there is no software fix but the ordered replacement part (Synaptics Touchpad for T440, T550, ...) finally arrived and seems to be compatible. Unluckily my product does not carry any order number.

  1. After hardware replacement Windows keeps reporting an ALPS touchpad eventhough the new one gets successfully recognised as Synaptics touchpad by Ubuntu 16.04.3 LTS. Even a fresh Windows installation reports an ALPS touchpad. Maybe someone, who is into Windows drivers in general, can explain this behaviour. To put this to work under Windows, I installed "Synaptics UltraNav Driver for Windows 10 (64-bit) - ThinkPad L450, T450, T450s" v19.3.4.83 from 11 May 2017. Maybe others will work as well but some will definitely not install but report a missing device. Any attempt to uninstall previous drivers beforehand does not seem to bring any benefits.
  2. This does not yet put the touchpad to work. In device manager, the driver of the "ThinkPad UltraNav" needs to be updated manually and the Lenovo/Synaptics Pointing Device needs to be chosen from the list of all available device drivers including potentially incompatible ones.
  3. As soon as that has been done, without rebooting, the Windows Group Policy Editor needs to be used to stop Windows from automatically updating the device drivers for the touchpad. Otherwise, after a couple of reboots, the ALPS driver gets installed again and the touchpad will not work any longer. I blocked the device's "Hardware IDs" listed in the device's details tab (for me: "ACPI\VEN_LEN&DEV_200D", "ACPI\LEN200D", and "*LEN200D".) The policy is Computer Configuration/Administrative Templates/System/Device Installation/Device Installation Restrictions/Prevent installation of devices that match any of these device IDs. Of course the policy needs to be enabled too.
  4. Afterwards one may check if the policy is in action by making Windows try to update the driver online. It should fail and report "The installation of this device is forbidden by system policy." then. If not, just rollback to the previous (Synaptics) driver.

Edit: My solution above still works (now using the driver for T440s version 19.0.17.115 gggr01ww) but the user experience is not as good as with the original device. Two-finger scrolling sensitivity often (but not always) feels awkward. Pinch & zoom is not supported. Full height swipe or three finger swipe to cycle through open applications is not supported. The Synaptics driver offers some options for TwistRotate and ChiralRotate but I don't need that. I really think about putting the original device back in, accepting to reboot every couple of hours.

Now my last hope is turning it into a Windows Precision Touchpad somehow. This article (https://www.windowscentral.com/how-enable-precision-touchpad-drivers) advises to get a specific Lenovo driver for Synaptics Touchpad owners (n1mgx14w) and install it manually via the device manager. I haven't tried that yet but due to the challenges it took to get the Synaptics touchpad running at all (especially that it required to disable automatic updates for the device) I don't have much hope.

Edit 2: Now I've followed either of the tutorials, mentioned by Frank Breitling and myself, to turn the touchpad into a Windows Precision Touchpad. I experienced complete failure of all built-in HID devices but the touchscreen again as well as both touchpad and trackpoint with its buttons only partially working, i.e. all three hardware buttons perform an immediate left click, no context menu, no dragging 'n dropping.

Edit 3: I finally switched back to the original ALPS touchpad. The function will still fail more or less regularly, but thanks to the hint to the devcon tool (from Windows SDK, also shipped with the Intel Bluetooth driver on my device) in the article linked by Frank Breitling, I now can restart the device/driver by calling as Administrator:

devcon.exe restart "@HID\VID_0483&PID_91D1&COL02\7&1EE98EEF&0&0001"

I just listed all devices and tried some HID devices until restarting the mentioned one had the desired effect. I hope this will still help somebody.

  • This is very interesting. I also have trouble with my Alps UltraNav would like to replace it with something better. Is your Synaptics touchpad detected as a precision touchpad in Windows 10? – Frank Breitling Feb 18 '18 at 14:04
  • I believe it is not recognised as Windows Precision Touchpad, because the only option the Windows 10 Touchpad config dialog offers is a sensitivity drop down list. By accident I saw a whole lot more options on a different notebook and grabbed a copy of the Windows Precision Touchpad registry settings, imported them on my ThinkPad but nothing changed. Thus, no support I guess. – Kristian Feb 24 '18 at 16:16
  • Have you seen the Enable Precision Drivers On Synaptics Touchpads (tutorial!) at the verge forum discussed in Precision Touchpad Driver at the HP forum? It worked for me with a HP Spectre! – Frank Breitling Feb 24 '18 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.