I have Refind 0.11.2 installed at /Volumes/ESP/EFI/BOOT. My main system is macOS 10.13.1, and I have a Windows 10 and Ubuntu partitions.
Refind had been working very well so far (apart from the occasional boot coups after macOS updates), but today when trying to boot to my other partitions, it remains stuck on the "Scanning for bootloaders" message for 15+ minutes.

I tried running refind-install again and it completes without error. I also replaced my (slightly custom) configuration by the provided refind.conf-sample.
I am still able to access my macOS partition by keeping alt pressed when booting.

  • I'm having the same issue on a Dell XPS 15 running rEFInd 0.11.2. I resized some partitions and deleted some others last night and now it hangs on Scanning for bootloaders. I've tried the default config, removing /boot/EFI/refind and reinstalling. All to no avail. I've checked the GPT is ok, fscked the EFI partition and all check out. – Wes Dec 22 '17 at 23:20

Following the steps taken by Wes described in their comment, I fixed the issue by:

  1. Running diskutil repairVolume on my ESP partition
  2. Deleting the refind directory, which had been upgraded several times over time (/Volumes/ESP/EFI/BOOT)
  3. Ran the refind-install script again, with SIP disabled

The "scanning for bootloaders" issue is now gone, and I can boot into my Windows partition. To access macOS, I still boot using the original bootloader (keep alt pressed at boot to access it), otherwise I get a question mark after the loading screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.