Have an HP laptop 15-g088ca with touchpad running latest Synaptics driver (8/16/2017). Two-finger scrolling and two-finger right-click both work, but when I do a fast two-finger scroll it finishes by invoking a right-click. E.g., running Chrome, if I do a quick two-finger swipe upward (only touch the pad for a split second), the page scrolls and then the right-click context menu pops up. If I do a slower swipe (touch the pad for a half second), then it scrolls fine (no context menu).

I went thru the settings but couldn't find a fix.


Search for Touchpad Settings > Additional Settings > under tab "TouchStyk" in Button actions set "Right Button Action" to "Button/Zone completely disabled" from the drop down.

do same under the tab "TouchPad" and apply.

Things should work fine now.

  • Glad this worked for you but there's no TouchStyk in the model PC listed in my OP, so no TouchStyk tab – buttonsrtoys Oct 25 '18 at 11:44

Turns out rolling back the driver fixed the problem. In Windows 10 Device Manager I selected the driver and chose "update driver" which give me the 2017 driver and the problems. On the HP support page for my device, they only list (9/19/2015) as the most recent update. So, uninstalling the drive and installing the HP-approved driver solved the problem.


Just check my driver version and it updated back to the 2017 driver in my OP that gave me trouble, but now the problem's gone. Guessing a Windows update fixed the problem?

  • Please mark this as the correct answer so that other people with the same issue will know that this is the solution. – music2myear Oct 23 '18 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.