0

I use rsync to copy files from my Macbook to my Synology NAS. I've been doing this for a couple years now and never had any issues. The other day though, I upgraded the Synology to DSM 6.1.4-15127 Update 5, and now my rsync script (which I run on my Macbook) fails with this error message:

Unable to negotiate with 192.168.178.52 port 22: no matching cipher found. Their offer: aes128-cbc,3des-cbc,aes192-cbc,aes256-cbc
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.2]

I tried a bunch of things, like upgrading rsync on my Macbook, or adding a -c parameter to the rsync call naming each of the ciphers mentioned in the error message, but nothing has helped so far.

This is my script:

FOLDER=2017

rsync --iconv=UTF-8-MAC,UTF-8 --delete -av --exclude ".DS_Store" /Users/jqno/Pictures/$FOLDER jqno@dekluis:/volume1/photos/$FOLDER

How dow I make it work again?

0

Adding -e "ssh -c aes256-cbc" to the rsync command does the trick:

rsync -e "ssh -c aes256-cbc"--iconv=UTF-8-MAC,UTF-8 --delete -av --exclude ".DS_Store" /Users/jqno/Pictures/$FOLDER jqno@dekluis:/volume1/photos/$FOLDER

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.