7

Since some time I can not connect to a local samba share anymore. When I try to access \\<server ip>\drive, I get the following dialog:


Error message

When connecting using the command line, using the command net use Z: \\<server ip>\drive, I get the following error:

System error 1272 has occurred.

You can't access this shared folder because your organization's security policies block unauthenticated guest access. These policies help protect your PC from unsafe or malicious devices on the network.

My setup is as follows:

The share is on a Ubuntu 16.04.3 server, with my samba configuration as follows:

[global]
workgroup = WORKGROUP
server string = Samba Server %v
netbios name = server
security = user
map to guest = bad user
dns proxy = no

[drive]
path = /media/Drive1
browsable = yes
guest ok = yes
read only = no
create mask = 0755

My client is a Windows 10 Education edition PC, Version 1709, OS Build 162.125. There is no workgroup or local domain. My sharing settings are: - Network discovery on - File and printer sharing on - Use user accounts and passwords to connect to other computers - Enable file sharing for device that use 40- or 56-bit encryption - Turn off password protected sharing

For the rest I have seem a lot more questions that deal with these issues, but none of the solutions worked for me. Also, I could not find questions regarding system error 1272. Any help on how to enable connecting to remote shares is appreciated.

2

Most of the current answers work by lowering the security on the client side. It is not enforcing the restriction in Windows 10 / Windows Server that was added for security purposes - it requires adjusting each of your clients.

A different approach is to raise the security on the server side and remove any mapping to guest accounts, which is the main issue

ADD THESE LINES

   [global]
   client min protocol = SMB3
   client max protocol = SMB3
   restrict anonymous = 2
   encrypt passwords = true

REMOVE

  • the map to guest option (which I had as bad user)
  • any 'guest ok' line in your smbd.conf

restart samba and you'll be prompted for a username/password instead.

  • 1
    This was exactly what I needed to do in my Samba configuration also - thank you! – Fallso Jun 27 at 10:50
1

Maybe it's a problem with your group policy settings:

https://support.microsoft.com/en-us/help/4046019/guest-access-smb2-disabled-by-default-in-windows-10-server-2016

  • Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – bertieb Feb 13 '18 at 19:38
  • When you would add this as a summary, I would make it an accepted answer – AZWN Jul 6 at 13:27
0

The answer by dude solved this issue for me.

Here's the relevant text from the "Guest access in SMB2 disabled by default" article

If you want to enable insecure guest access, you can configure the following Group Policy settings:

Computer configuration\administrative templates\network\Lanman Workstation "Enable insecure guest logons"

Note By enabling insecure guest logons, this setting reduces the security of Windows clients.

You can get to the group policy manager by running

gpedit.msc

Here's a screenshot of the setting in the ui Microsoft Group Policy Tool

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.