0

I'll try and keep this as concise as possible, here are the order of events:

1) New PC, has Windows on it.

2) I installed Ubuntu on my new PC

3) I disabled Secure Boot so that I could use proprietary Nvidia drivers (I was prompted to do this)

4) I needed more space on my Ubuntu FS so I boot up the Gparted Live Disk

5) I resize my FS, growing it to fill unallocated space

6) Operation successful, shutdown PC and boot up into Ubuntu

And now everytime I boot Ubuntu

1) I am prompted to cancel a system filecheck with ctrl + c (I do not cancel it)

2) I see this:

Please enter passphrase for disk ST1000DM003-12B102 (cryptswap1) on none!

There is a box below it that looks like I can enter text, but nothing seems to happen when I type or press enter. I did not set up any sort of "cryptswap", I don't even know what that is. Does anyone know what is happening or how I can get around this? I need to access my Ubuntu install for work so this is really freaking me out. Worse case scenario I guess I could reinstall it but I would lose a lot of time and work so I'm hoping there is another solution

0

I fixed this, in case anyone else like me is seeing a message about cryptswap after resizing a partition with Gparted here is the solution:

1) Boot up Gparted Live Disc again

2) Select the partition labeled "linux-swap", take note of it's name and right click and delete it.

3) Right click the unallocated space, select new, give it the same name and set the type to "linux-swap". If "linux-swap" isn't an option, you can make it ext4 and then format it to linux-swap afterwards.

Then it will work! Ubuntu took quite a bit longer to boot (~20secs longer) but just stick with it and everything will run smoothly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.