1

I'm running Kali (x64) on a Live USB. Unfortunately, it doesn't detect my integrated Wi-Fi on my laptop (Leapbook M100), and other stuff like battery, the AC to charge the battery and the bluetooth, but at the moment I'd like to focus on the Wi-Fi and will create a different topic for the others once this is fixed/if it's even possible to fix it.

Things I've tried:

  • I typed in the terminal "ifconfig". This is what I get:

    ifconfig

  • Interestingly enough, everything on Windows 10 seems to work properly, so I went to System Information and this is what I got from the "Network -> Adaptar" tab:

    Text file download from mediafire

    I would've posted the text here directly, but it marks it as spam. Probably cause it's too long.

  • So, I assumed my Wi-Fi was the Realtek one. There for, I tried modprobe rtl8192cu as suggested here, but I get nothing once again.

    modprobe

    But if I write modprobe rtl8188cu, I do get the fatal error. Unfortunately, when I tried to access /boot/config-4.13.0.kali1-amd64, I get a permission denied error and from what I read here I cannot access it since it's on a Live USB.

  • I typed iwconfig which showed only the following:

    iwconfig

  • I found this thread on Ubuntu, but unfortunately the link leading to the Realtek website is dead. I checked manualy all of the WLAN pages on Realtek but I couldn't find the appropriate driver.

  • I don't see a link to download the rtl8192cu on the Linux Wireless drivers page either.

  • I typed lsmod | grep rtl, which I found in a thread called "[SOLVED] RTL8188CUS Driver Install" whose link I cannot post due reaching maximum number of links (7) (error says "You need at least 10 reputation to post more than 8 links", doesn't look like it includes the 8th), but I couldn't follow the rest of the procedure due to not having any internet (the laptop doesn't have a RJ-45 connector). That shows the following:

    lsmod

    I did plug in another Wi-Fi USB but it doesn't detect that one either. I know this Wi-Fi works because I can use it on other machines, including other types of Linux, but on the Linux distros it has only ever worked once they were installed, never during Live boot, which is weird. Also, all of my USBs on the laptop work, I've tested.


What else can I try? Is the only way to "repair" it to install Kali on the laptop? I'd really like to avoid that. From what I've heard, and especially since I'm no pro in the Linux industry, it's not the brightest idea and that it's better to just boot it live when you need it due to security holes.


Edit: New commands I tried:

lshw and hwinfo don't work. These packages don't seem to come with the Kali.

nano /proc/devices shows: 1 mem, 4 /dev/vc/0, 4 tty, 4 ttyS, 5 /dev/tty, 5 /dev/console, 5 /dev/ptmx, 7 vcs, 10 misc, 13 input, 21 sg, 29 fb, 81 video4linux, 116 alsa, 128 ptm, 136 pts, 180 usb, 189 usb_device, 226 drm, 247 media, 248 hidraw, 249 bsg, 250 watchdog, 251 rtc, 252 dax, 253 tpm, 254 gpiochip and then Block devices:, 259 blkext, 7 loop and the following numbers are all for sd: 8 65 66 67 68 69 70 71 128 129 130 131 132 133 134 135, 179 mmc.

ls /sys/class/net only shows lo just like the ifconfig picture.

lspci didn't show anything even remotely similar to wireless things, only Host bridge (SoC transaction register), VGA compatible controller, Multimedia controller, Signal processing controller (power management), USB controller, Encryption controller and ISA bridge (PCU).

nmcli connection show only shows one line containing the following: NAME UUID TYPE DEVICE, but no information under those.


Edit2: Thanks to UncertainWhatNameToPickHere, downloading "kali-linux-2017-W52-amd64.iso" from the link provided in his comment (cannot post here due to maximum number of links) and booting it has fixed the issue. My Wi-Fi is working during live boot, but I've not tested if it will still work if I were to install Kali on the laptop.


Edit3: The Wi-Fi also works after installing the mentioned Kali Version. ^^

2
  • 3
    Don't post thumbnails of screenshots of photos of a screen using your flash. It's totally unreadable. Copy/paste the output here and use preformatted text using { and } instead. – Teun Vink Dec 27 '17 at 23:07
  • 1
    @TeunVink It's visible now. I thought putting the "s" at the end only made it smaller on the preview in the post but when clicked upon they'd get bigger, but apparently not. So I've removed the "s". – DoombringerBG Dec 27 '17 at 23:49
0

Downloading the latest Kali Weekly Build https://cdimage.kali.org/kali-images/kali-weekly/ makes a difference. They're currently at Week52, the last build for 2017 and it would include hardware updates and contributions from the community.

In addition, updates, albeit not always the most recent updates, but updates to the vulnerability signatures like Metasploit are more current inside the weekly builds.

1
  • 1
    The Wi-Fi also works after installing the Kali. Just thought you might want to know. ^^ – DoombringerBG Dec 28 '17 at 22:00
0

does nmcli n on and than nmcli d wifi work? I once had this issue but it still worked, it just wasn't enabled. nmcli --ask d wifi connect <WiFi name> to connect if it works.

1
  • 1
    When I typed nmcli n on and nmcli d wifi there were no messages. Like, I wrote each and pressed Enter and went on to the next line, no errors no confirmations, nothing. When I wrote nmcli --ask d wifi connect <Wifi name> I got an error saying Error: No Wi-Fi device found. The ifconfig and iwconfig still show the same information as the original pictures posted in the first post. – DoombringerBG Dec 28 '17 at 15:18
-1

If you installed and partitioned your USB properly with the correct Kali image, your OS should have no problem utilizing the internal hardware. With that said, your images are too difficult to read. I would recommend trying to reinstall Kali Linux onto your USB again following the steps given. Additionally, make sure that all of your hardware specifications meet or exceed the requirements given.

6
  • 1
    My system does meet the requirements and it exceeds them. I've installed the Kali on the USB as it was shown in the official guide. – DoombringerBG Dec 28 '17 at 3:49
  • @DoombringerBG To clarify, are you using the latest Kali weekly build ? cdimage.kali.org/kali-images/kali-weekly Looked up your Leapbook, nice laptop, congratulations. Is it fairly new ? When I've tried the latest laptops with Kali and the days of Backtrack, it took some time for the authors at SecureComputing and the community to "catch up" – 123456789123456789123456789 Dec 28 '17 at 11:50
  • 1
    Thank you for the compliment on the laptop, in reality it's a piece of shit. I regret buying it. I bought it in July-August this year. I think it's quite new, but from what I managed to find out a few months ago, all of the parts seem to be from china and japan and don't look like they're new themselves. I downloaded the x64 version from the official Kali download page. I followed the link you provided and compared the SHA256SUMs and they don't match. Would you recommend trying out the weekly build? – DoombringerBG Dec 28 '17 at 15:14
  • 1
    @UncertainWhatNameToPickHere Just downloaded and booted up the "kali-linux-2017-W52-amd64.iso" version from the link you provided. My Wi-Fi is working. – DoombringerBG Dec 28 '17 at 19:24
  • @DoombringerBG I'm glad that worked! I posted an answer with my previous comment and I envy your Kali Leapbook. – 123456789123456789123456789 Dec 28 '17 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.