My infrared port is not working on my Windows XP SP 3 (Thinkpad X60). I can see it Device Manager, and it's status is, that it is working probably. The problem manifests in several ways.

Originally I was trying to transfer data from my Polar RS800CX watch, and the Polar ProTrainer 5 software gave me the this error message: "Communication port couldn't be opened".

Then I tried to connect the watch to another computer, and the infrared connection was established immediately. I then tried to connect the other computer to my Thinkpad X60. The other computer again immediately showed the Wireless Link icon "'computername' is in range" in the notification area. But nothing is shown on the Thinkpad, and a file transfer to the Thinkpad is unsuccessful with an error message that reports that "the target machine actively refused it [the connection]".

This brings me to conclude that the infrared support in Windows on the Thinkpad is somehow broken. This is further supported by the fact that I can't find the "Wireless Link" icon in the Control Panel and when I try to run the irprops.cpl nothing happens.

So the question is, how to reinstall the infrared support?

Some of the solutions that I have explored is:

  • I have tried to disable/enable the infrared in the BIOS - to trick a re-installation.
  • The IR modules settings on the other computer that can get a successful IR connection is an exact match to the ThinkPad that can't get a connection.
  • The was a problem in Windows XP SP 2 with the Wireless Link icon - MS KB article - but that hotfix can't be applied on SP 3 installation. I also guess that the hotfix is included in SP 3.

Any other suggestions?

4 Answers 4


It is possible that some other application is already connected to the port. The first culprit I would look at is the THINKVANTAGE suite that is installed. That software seems to tie in to the hardware at a very low level in some instances.

There could be some resource conflicts that might be keeping it from working like in the "old" days before PnP however this is probably an outside possibility. Nonetheless if you check the hex address for the port you can usually sort this out. Windows also has the ability to use different hex addresses for the port so make sure all the settings in the bios and windows are consistent with one another.

If you have the ability to look at the hex address in a hex monitor, then you can also get a remote, put it next to the IrDa port and look to see if any data is changing in the register.

Last but not least, some laptop cases contain the IRDA window without any corresponding hardware. I've seen this a time or to as well. I was shocked to find out there was not actually an IRDA port inside because from the outside there was all the indication there was.

  • Which part of the ThinkVantage suite do you suspect? (I don't have the Access Connections software installed.) I'm not 100 % sure what I should check in regard to the hex addresses, the I/O Range? Thanks for the input! Jul 25, 2009 at 13:33
  • yes. watch the I/O range to see if it is seeing anything come across.
    – Axxmasterr
    Jul 25, 2009 at 18:02
  • Any pointers to a "hex monitor"? I have searched in vain. But if the point is to validate that the port works, I would think that I have covered that, by having the the other computer see it in range. Or am I missing something? Jul 26, 2009 at 8:20

I don't have a Thinkpad anymore but when I had one I spent some time working with IR comms. The Thinkpad IR modules used to support a number of IR modes - SIR (standard) and FIR (Fast). There are other modes - MIR and VFIR that newer models might also support. It should be possible to set the mode in the properties dialog for the IR device, it certainly used to be the case on the Thinkpad T30\T40 series. Setting it to FIR only would prevent it communicating with standard devices.

It is worth checking to see if this option is available and if so see if modifying it makes any difference.

There were some XP SP2 issues with IR being disabled - this MS KB article has some details.

  • Good suggestions! I have tried various IR modes, and finally when I got an successful connection on the other computer (also a ThinkPad), I validated that a the settings of the IR modules was an exact match on the ThinkPad. I had a look on the MS KB article, but the hotfix can't be applied on a SP 3 machine. Jul 26, 2009 at 8:24

start > run > type services.msc

check if the Infrared Monitor (Irmon) Service is started and set to start automatically.

  • Thanks for the suggestion. But I have already checked that. Oct 28, 2009 at 17:31

A method to check if the port is physically working is to use the various thinkpad utilities to attempt a connection while pointing a digital camera at the port. Watch the viewfinder and you should be able to see the infrared light emitted by the port. While your eyes cannot see infrared, CMOS and CCD sensors in the cameras do, and will represent the light as whitish.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.