2

I have a computer with Windows 10 Professional 64-bit.  Specifications:

  • CPU: AMD A6 6400K 3.90GHz
  • Motherboard: GIGABYTE GA-F2A68HM-S1
  • RAM: GEIL GV34GB1600C8DC DDR3 4GB (2X2GB) PC3-12800 1600MHz
  • PSU: COOLERMASTER MASTERWATT 750W
  • Antivirus/Firewall: ESET Internet Security

For some unknown reason my computer does not recognize any mouse I connect to it. I tried an old wired USB Logitech mouse, a Microsoft Wireless Mobile Mouse 1850 and a Wireless Desktop 850 set with a keyboard (keyboard was working fine but mouse was not). I tested all mouse devices on another computer and they all work fine.

I tried on a USB 3.0 port, on an other USB 2.0 port (front and back side), restarted, shut down (removed power supply), and reset BIOS to default – without results.

Legacy USB was enabled by default on BIOS. I disabled it but nothing happened.

  • My USB Camera works fine.
  • My USB Printer works fine.
  • My USB Speakers work fine.
  • My USB Stick works fine.

All my USB devices work except my mouse, so I don't think it's a USB driver issue.

One other strange thing is that BIOS GUI recognizes my mouse but, when I boot with Windows, Device Manager shows no mouse connected, no "unknown device" and the Hardware tab on Mouse Properties is empty (shown below). Same thing happens in Safe Mode.
Mouse Properties - Hardware tab

I really don't want to format my PC just because it doesn't recognize my mouse.

  • Seems like I saw a computer once where there was a setting in the bios about running the mouse in some sort of legacy mode that windows 10 didn't like. You might look for such a bios setting and just try changing it. – ashbygeek Dec 29 '17 at 15:38
  • Maybe try reinstalling your usb drivers? – DrZoo Dec 29 '17 at 16:25
  • @ashbygeek I disabled legacy mode but it didn't solve the problem. – Zerthimon Dec 29 '17 at 22:43
  • @DrZoo all my USB devices work fine (camera, printer, stick etc). Only mouse devices are unrecognizable. I don't think there is a problem with my USB drivers. – Zerthimon Dec 29 '17 at 22:46
  • There are a couple general troubleshooting things you could try before completely re-installing windows: sfc /scannow go to device manager and uninstall the driver for the mouse so that it will completely re-install. – ashbygeek Dec 31 '17 at 0:58
0

Finally I found the solution!
I downloaded and installed Mouse and Keyboard Center 3.2 and after a reboot mouse came back!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.