1

Before possibly downvoting or closing/flagging this post as duplicate please notice that I'm working with a CLI Ubuntu so installing virtualbox guest additions doesn't help. I have already tried it. I have also tried other solutions: for example this or this and many other posts. I wasn't sure if I should ask this question in macOS, Ubuntu or SuperUser stackexchange so I asked it here.


I have an Ubuntu Minimal 16.04.3 LTS tty1 installed on VirtualBox Version 5.1.30 r118389 on my MacBook running macOS EL Capitan version 10.11.6. When I fullscreen the window with left cmd ⌘+f the working window of the CLI Ubuntu does not scale up.

Expected solution:

Almost all of the solutions I have found on the internet require editing these files:

  • /etc/default/grub
  • /etc/grub.d/00_header

Steps:

  1. Hold shift ⇧ while booting to go to GRUB menu
  2. press C to go to GRUB CLI
  3. enter the command set pager=1 to make sure you see long returns
  4. enter the command vbeinfo or videoinfo and press enter multiple times to see all of your options for screen resolution. On my mac I have a screen resolution of 2880x1800 and from vbeinfo I chose 1152x864x32.
  5. press shift ⇧ +esc to go back to GRUB menu and then boot in normally
  6. When booted edit /etc/default/grub with superuser and applying either of the edits:
    • changing the value of GRUB_CMDLINE_LINUX_DEFAULT="splash quite" to quiet vga=0x0365 or nomodeset or quiet text vga=0x160 or splash vga=792 ...
    • uncommenting the line GRUB_GFXMODE=... and editing the value to the one selected in step 4
    • Adding a line below as GRUB_GFXPAYLOAD=... with the same value as above or keep
  7. Editing the file /etc/grub.d/00_header with superuser privilages and apply the edits:
    • editing the line if [ "x${GRUB_GFXMODE}" = "x" ] ; then GRUB_GFXMODE=1152x864x32 ; fi to match the resolution chosen in step 4
    • Adding the line if [ "x${GRUB_GFXPAYLOAD}" = "x" ] ; then GRUB_GFXPAYLOAD=1152x864x32 ; fi below
    • Find the line set gfxmode=${GRUB_GFXMODE} and add set gfxpayload=${GRUB_GFXPAYLOAD} below
  8. update grub update-grub or update-grub2 with superuser
  9. reboot

During the booting process or in the GRUB, the CLI matech the window size but when it boots up the main command line is still small! I have tried other resolutions and other possible combinations but none works. I would appreciate if you could help me find the problem and solve it.

1

I think I have found the solution. Well partly! With the below solution you will be able to adjust the resolution to any of the options available in GRUB>vbeinfo but it will not adjust automatically to fit the window.

Solution:

(From this post) the only file you need to edit is /etc/default/grub. So after step 5, edit the file and

  1. change the value of GRUB_CMDLINE_LINUX_DEFAULT="splash quite" to nomodeset
  2. find GRUB_GFXMODE=... line and add GRUB_GFXPAYLOAD_LINUX=... afterwards, with the resolution you chose from step 4.

And then continue from step 8 to update GRUB and reboot.

P.S. I also tried the issue with Ubuntu 17.10 on Windows 10, so the issue has nothing to do with the version of Ubuntu on either host OS.

0

You need to install in guest OS virtual box guest additions and on some Ubuntu versions GCC support too to get the biggest possible size of screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.