-2

I'm facing an issue that is quite familiar with this one but I can't really find out a solution, I've tried diskpart and clean command and also clean and create partition primary but all can't work (screenshot below)

I'll explain how my USB got broken, first I've downloaded Centos everything iso (8GB) and also Rufus and later I plug my 16GB USB and let Rufus burn (not sure does Rufus burn or extract) the everything iso into it, about half to 2/3 of the process I got an error syslinux not exist or something like that and the whole process stops.

Later my USB can't be read/list on file manager, I've opened the disk manager (also the screenshot below) it got listed there, but with no storage, and can't run clean or create partition primary command.

As what Rufus' developer said here, it's because Rufus take some kind of config file out and didn't put it back if the process if terminated half-way, but the method he provides, can't work since the USB isn't even listed on Rufus.

With the above condition I can't really find out a way to get my USB listed and format it in order I can use my USB, anyone can help me out?

Screenshot here

  • You tried it in other computers right, and linux? Did it show up as a device in linux, writeable? Or you already selected the "it's broken" answer after less than an hour, did you chuck it in the trash & call it a day? – Xen2050 Dec 30 '17 at 10:40
  • @Xen2050 It was broken last day I've tried it on Linux in my VM and also my laptop and PC it was running Rufus on my PC and the screenshot is from laptop and VM is running on PC – Andrew.Wolphoe Dec 30 '17 at 10:41
0

If Disk Manager says "No media", it means that your flash drive is probably dead. What usually happens is that flash drive manufacturers use the same controller chips as the ones you would find on a card reader (e.g. SD card reader) in flash drives, even if the flash memory cannot be removed.

Then, when the flash memory dies, or some hardware issue occurs, the controller detects that it can no longer write to the flash memory and falls back to one of the default behaviour of a card reader, which is to declare that the "flash media" is no longer present, which is what Windows also reports as a result, as per your screenshot.

Unfortunately, since this is indicative of bad flash memory, you probably won't be able to reformat your drive. You may try your luck at locating manufacturer-specific low level restoration tools (but these tools are usually kept private and not made available to the general public) to see if you can reset the internal flash drive controller into "re-mounting" the flash, but you have to bear in mind that you most probably have bad flash memory on this drive, therefore, once you write to one of the bad flash blocks, you'll probably run into the same issue again or get data corruption.

You may also try your hand at reformatting your drive in a different OS if you have one (e.g. Linux), just in case, but by the looks of it, since it seems your flash memory is defective, you're probably better off using a new flash drive.

So, to summarize what probably happened:

  1. While Rufus was writing data, it happened to do so on flash memory cells that were defective
  2. The internal flash drive controller detected that the flash memory was defective because the operation failed to complete, tried to recover (there's usually a wear-levelling algorithm that can declare a handful of memory cells as defective and try to use spares... but that will only work as long as there are spares to be used), failed to do so, and, because the flash drive controller firmware is designed to work both for a flash drive with non-removable memory, as well as a card reader, with removable one, it fell back to card reader behaviour, and declared that the flash memory had been "removed".
  3. Windows, which doesn't handle card readers any differently than flash drives, got notified that the "media" had been removed, which of course prevents you from reformatting it or accessing any data on it.
0

If you can see the drive in this pc, open disk management and at the bottom part you will see your disk that is unlocated(identify it by the capacity). Then right click and choose the first option(i dont know that would be "shrink volume" or "extend volume" but the option will be at the top) enter your full volume of usb then follow the progress.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.