Using a Galaxy S7, I am suffering heavy stuttering when using game streaming apps in the form of skipped audio and video every 3 seconds. It works stutter-free with the Motorola Moto G (2013) and the iPad Air 2, and stutters on the Galaxy S7 in the same manner across all game-streaming solutions both NVidia-Gamestream based and otherwise that I tried, and is reported for Moonlight by almost exclusively Galaxy S7 users. Hence it should be device-specific.

Specifically I tried

  • Stream Theater (VR app, Gamestream based).
  • Moonlight (Open-Source Gamestream client for various platforms)
  • Trinus VR (not Gamestream based)

From testing it is pretty clear, that the issue is caused by the mobile network connection: Flight-mode with Wifi and GPS enabled stops the stuttering. The mechanism (software? radio interference?) is unclear however.

Asking Samsung support about it resulted only in a "this is not officially supported, ask the app provider" answer.

Diagnosis Results

  • When I connect with Moonlight (iPad Air 2, Moto G) to the USB-Dongle network, everything is running fine.

  • When I connect the Galaxy S7 in either Moonlight or Stream Theater to the USB-Dongle network, I have microstuttering. It is playable, but not enjoyable. The stuttering is more pronounced in moonlight – in Stream Theater at least the audio is stutter-free.

  • I verified that it is connected to the USB-Dongle network by unplugging the Dongle and trying again. Both moonlight and Stream Theater connect, but in this setup, both suffer entirely unplayable stuttering (and moonlight even disconnects).

  • Rebooting / closing all apps makes no difference.

  • Flight Mode with Wifi enabled resolves the issue, but it is unfeasible for longer usage.

  • The issue still occurs on the Galaxy S7, when the SIM card is removed, and doesn't occur on the Moto G when inserting the SIM card and connecting to the mobile network.

  • Location services do not affect the issue, regardless of mode (Wifi/GPS/Wifi+GPS): Using them in Flight mode doesn't cause stuttering, and disabling them without Flght mode doesn't fix it.

My Setup (should not be relevant, just for completeness)

Only for completeness. Since it works with other devices or with the Galaxy S7 in Flight mode, and the issue is reported almost exclusively by Galaxy S7 users, the setup should not be relevant.

[Internet]–––––[ISP Wifi Router]  <))))  [Laptop]  <))))  [Mobile Device]
  • An ISP-provided Wifi router (good for browsing, sufficient for video streaming and gaming, impossible for game-streaming).
  • An USB wifi dongle with access-point mode, which I use as a hotspot. (Wifi card of laptop doesn't support hotspot mode.)
  • The gaming laptop is "10.0.0.xx" in the ISP-Router network and "192.168.137.1" in the hotspot network.
  • The hotspot is created using Windows 10's builtin hotspot mode (which also allows explicitly selecting which Wifi adapter to use to connect to the ISP-Router, and which to use to create the hotspot).
  • The gaming laptop is running Windows 10 Home, 64bit with a GTX 1050 Ti.

See also

up vote 0 down vote accepted

Update: The solution has stopped working for me, leaving only flight-mode with enabled Wifi.

Apparently, setting the screen-resolution to HD = 1280x720 removes the stuttering for the Galaxy S7 too, providing a more viable solution than flight mode.

This can be achieved by using the "Performance Mode" setting in the notification-bar menu, by customizing the settings of one of the modes accordingly. It doesn't matter if one uses "Game Mode" or "Performance Mode" for this.

screenshot_20180105-011814: Press and hold "Performance Mode" button. Press "Game". Press "Customize". Select "HD" screen resolution, then press "Apply".

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.