0

I've recently configured my openVPN to route all traffic through TOR using this guide. This work perfectly when using the OpenVPN client Tunnelblick on macOS however, when attempting to contect with the OpenVPN IOS app no traffic is routed desite seeing the vpn symbol in the status bar and the logs confiming this.

Below is a snippet of logs

0 [dhcp-option] [DNS] [84.200.69.80] 
1 [dhcp-option] [DNS] [84.200.70.40] 
2 [redirect-gateway] [def1] [bypass-dhcp] 
3 [route-gateway] [10.8.0.1] 
4 [topology] [subnet] 
5 [ping] [10] 
6 [ping-restart] [120] 
7 [ifconfig] [10.8.0.3] [255.255.255.0] 
8 [peer-id] [0] 
9 [cipher] [AES-256-GCM] 

2017-12-30 17:15:24 PROTOCOL OPTIONS:
 cipher: AES-256-GCM
 digest: SHA256
 compress: NONE
 peer ID: 0
2017-12-30 17:15:24 EVENT: ASSIGN_IP
2017-12-30 17:15:24 TunPersist: saving tun context:
Session Name: <REDACTED>
Layer: OSI_LAYER_3
Remote Address: <REDACTED>
Tunnel Addresses:
 10.8.0.3/24 -> 10.8.0.1
Reroute Gateway: IPv4=1 IPv6=0 flags=[ ENABLE REROUTE_GW DEF1 BYPASS_DHCP IPv4 ]
Block IPv6: no
Add Routes:
Exclude Routes:
DNS Servers:
 84.200.69.80
 84.200.70.40
Search Domains:

2017-12-30 17:15:24 Connected via tun
2017-12-30 17:15:24 EVENT: CONNECTED @<REDACTED> (<REDACTED>) via /UDPv4 on tun/10.8.0.3/ gw=[10.8.0.1/]
2017-12-30 17:15:24 SetStatus Connected

The Connection details in the app show <300KB of traffic despite being connected for over 20 mintues.

I found a someone with the same issue however, their solution did not work as these flags were already set in my OpenVPN config. For refrence below:

port 1194
proto udp
dev tun
user nobody
group nogroup
persist-key
persist-tun
keepalive 10 120
topology subnet
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "dhcp-option DNS 84.200.69.80"
push "dhcp-option DNS 84.200.70.40"
push "redirect-gateway def1 bypass-dhcp"
crl-verify crl.pem
ca ca.crt
cert server.crt
key server.key
tls-auth tls-auth.key 0
dh dh.pem
auth SHA256
cipher AES-128-CBC
tls-server
tls-version-min 1.2
tls-cipher TLS-DHE-RSA-WITH-AES-128-GCM-SHA256
status openvpn.log
verb 3 

The OpenVPN configs are the same on both clients.

Any help would be much apreciated!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.