0

I want to setup a tor proxy in a vmware virtual machine. So I can use that as a proxy on my host machine.

I set SocksPolicy accept * in torrc, but not work.

  1. test in that vm machine,

    curl --socks5 localhost:9050 --socks5-hostname localhost:9050 -s https://check.torproject.org/ | cat | grep -m 1 Congratulations | xargs
    

    correct return

  2. test on my host machine

    curl --socks5 192.168.126.143:9050 --socks5-hostname 192.168.126.143:9050 -s https://check.torproject.org/ | cat | grep -m 1 Congratulations | xargs
    

    hang

    $ nc -v 192.168.126.143 9050
    nc: connect to 192.168.126.143 port 9050 (tcp) failed: Connection refused
    
0

At first, I think SocksPolicy control the listen address access. But it need use SocksPort to bind address, which looks werid ...

Anyway, this setting can solve the problem

SocksPort 0.0.0.0:9050 
SocksPolicy accept *   

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.