I'm trying to run DaVinci Resolve on Centos 7, but when I start the program from the terminal I get the following error:

error while loading shared libraries: libOpenCL.so.1: cannot open shared object file: No such file or directory

As best as I can tell, the library isn't installed on my system. When I tried to run yum install libOpenCl it said the library doesn't exist. How can I get this library installed on my machine?

  • OpenCL implementations depend on your GPU/CPU (or Intel/AMD have CPU ones), you'll need to install from manufacturer sites.
    – trapezoid
    Commented Jan 2, 2018 at 20:18

3 Answers 3


For Ubuntu, try:

How to install libOpenCL.so on Ubuntu

sudo apt update
sudo apt install ocl-icd-opencl-dev
  • 2
    did it with apt-get and it helped. Commented Oct 13, 2018 at 1:56
  • 2
    this is weird. I thought Resolve was a professionally designed program, yet the install instructions said nothing of this - why
    – Michael
    Commented May 9, 2020 at 20:29
  • This led me to installing ocl-icd on manjaro to get DaVinci Resolve 16 started even though opencl-mesa wa installed. Commented Jun 16, 2020 at 5:58

hi I noticed that my Davinci Resolve crashed with an OpenCL Clang message so on ubuntu this fixed it for me sudo apt install libopencl-clang-dev


Note: Below answer is to those who came across dependency related error while installing Graphics / OpenCL related errors. Hope the post saves times for someone facing similar issue.

While installing a graphic application in command line, it returned with errors related to OpenCL and nVidia. And had spent lot of time searching for a solution.

To fix the error, you can run the below command in ubuntu terminal

sudo apt --fix-broken install

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .