1

I think I've discovered a possible bug in Debian 9 Stretch.

When the system boots, or the user locks the screen, the number lock is always "off" - even when the keyboard LED indicates that it is "on".

  • I have tried enabling numlock at boot (in bios)
  • I have tried installing numlockx and editing the file /etc/default/numlockx
  • Restore num lock state on startup is enabled in the keyboard settings
  • I have a script which is run from a udev rule whenever my keyboard is connected. This script executes; numlockx on, xset b off

Note that I am using the XFCE desktop environment

Having the number lock state default back to "off" when locking the screen is a particular annoyance for me as I enter my password using the numberpad. (It's not just numbers but I can enter the sequence faster using one hand on the alpha part of the keyboard and another on the numberpad.)

I also have a startup script which enables numberlock and disables the "bell". (numlockx on, xset b off) This works when the user is logged in however does not work "system wide", or before the user is logged in, and does not work at the logon screen. Is there a way to enable numlock and disable the bell system wide?

Note: Disabled restore numlock state on startup in system settings and it now appears to be working.

Edit: No it isn't - the lock screen bug is still present.

  • Hi dude, I'm experiencing the same issue, did you find any solution to this? thanks! – BruneX Sep 8 '20 at 22:28
  • @BruneX Hi - no I didn't. However since then I've moved onto newer version of Debian. (Currently using 10, and the upstream rolling release one) and I've not noticed this issue. Which version do you currently have this problem with? – user3728501 Sep 9 '20 at 19:15
  • Hi @user3728501 I'm using Debian 9 Strech yet, I've planned to move to v10 but I wasn't able to do that yet. – BruneX Sep 10 '20 at 16:49
  • @BruneX I would recommend moving to the newer version if you can, I believe a bunch of bugs were fixed including some strange bug that crashed Thunar when a large number of files are created in the current directory a Thunar window is pointed at. You could also try posting on the debian forums, but they will probably tell you the same thing - upgrade because bugs are generally fixed in upgrades. – user3728501 Sep 12 '20 at 11:45
-1

I had the same problem, I solved it by editing /etc/lightdm/lightdm.conf as stated here.

  • Welcome to Super User! Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Jun 16 '18 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.