6

When I run the following command from an Administrative Command Prompt:

psexec64 -i -u "nt authority\network service" C:\Windows\System32\cmd.exe

I'm getting these error messages:

Couldn't install PSEXESVC service:
The operation completed successfully.
Error establishing communication with PsExec service on MYPC:
The operation completed successfully.

I'm running this on Windows 7 x64 SP1. The PSEXESVC service is installed and running. I get the same results when using the 32-bit version of psexec.

Any ideas how to fix this problem?

19
  • Can you get by without using the -i switch, if that makes a difference? Jan 5 '18 at 19:49
  • I just ran your command example and it worked. It took a really long time to connect to my local machine. Maybe your user account doesn't have the correct permissions. It's possible that security software is stopping this questionable behavior from completing.
    – HackSlash
    Jan 5 '18 at 20:01
  • Also, it installed the service, ran, and then deleted the service when it was done. Maybe you can't have two services running at the same time.
    – HackSlash
    Jan 5 '18 at 20:02
  • If you want to become System, use the -s parameter.
    – harrymc
    Jan 5 '18 at 20:34
  • 1
    Look over this post and see if you see anything helpful or related in it then: stackoverflow.com/questions/31683374/…. I'm not able to reproduce this error you get up top but that post seems to have some detail related to the issue I suppose. Jan 6 '18 at 16:37
1

As a workaround, try omitting the -i (interactive) switch, making the new syntax:

psexec64 -u "nt authority\network service" C:\Windows\System32\cmd.exe

According to PSExec's help for this switch:

Run the program so that it interacts with the desktop of the specified session on the remote system. If no session is specified the process runs in the console session.

With the -i switch you would normally get the new Command Prompt in a separate window. Without it, a separate window won't appear, but you'll still get connected to the new CMD.EXE process running in the context of the NT Authority\Network Service user account. You can verify this by running WHOAMI at the prompt.

4
  • 1
    As I've already written to you in the comments, this didn't work.
    – user626528
    Jan 12 '18 at 18:03
  • Meaning you get the same error? Jan 12 '18 at 18:37
  • yes the same error.
    – user626528
    Jan 12 '18 at 21:03
  • @user626528 Have you tried doing this while logged in with the built-in administrator account? Jan 12 '18 at 21:06
0

First I would try to run a local elevation with:

Does that work for you?

"c:\your_path\psexec.exe" -i -s cmd.exe OR "c:\your_path\psexec64.exe" -i -s cmd.exe

You should get something like:

C:\Windows\system32>whoami /user

USER INFORMATION
----------------

User Name           SID
=================== ========
nt authority\system S-1-5-XX

I have tried it on my computer which is in domain:

C:\app\tools\Sysinternals Suite>psexec -i -u "nt authority\network service" C:\Windows\System32\cmd.exe

PsExec v2.2 - Execute processes remotely
Copyright (C) 2001-2016 Mark Russinovich
Sysinternals - www.sysinternals.com

Couldn't install PSEXESVC service:
The network name cannot be found.

Make sure that the admin$ share is enabled.

C:\Windows\System32\cmd.exe exited on XXXX with error code -1073741510.

Producing:

Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>whoami /user

USER INFORMATION
----------------

User Name                    SID
============================ ========
nt authority\network service S-1-5-XX

My guess based on this is that the message Couldn't install PSEXESVC service: is connected to your network name.

Does it work for you if you try it this way?

"\\computer.domain.com\C:\app\tools\Sysinternals Suite\psexec.exe" \\computer.domain.com -u "domain\username" -p "passwd" -e -s cmd.exe

0
0

On my up-to-date 64bits French W10 , what works is networkservice without space :

psexec -i -u "nt authority\networkservice" cmd.exe

I hope i may help some of you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.