1

I have a Windows Server 2012 R2 that has a FileZilla Server in the IP (212.166.78.203) that I get from https://www.whatismyip.com/ I can access to this FTPServer from my computer, but not from another Windows Server 2012 R2. I guess I have to define a Firewall outbond Rule, but I don't know if it is better to do it on a Program Level or on a Port Level.

I've defined an outbond port rule but does not work,

But when I connect to the FileZilla Server using a FileZilla Client I got this error "ECONNREFUSED - Connection refused by server"

Anyway, in the protocol type I don't see the FTP protocol

enter image description here

I also created a Program rule for the FTP Client

enter image description here

anyway I don't see either the option to overwrite the other rules

  • 1
    Have you defined any rule from your computer? – vembutech Jan 5 '18 at 11:06
  • no, my computer is a MacBook (client), not a server – Nuñito de la Calzada Jan 5 '18 at 12:59
  • By default, ftp could use port 20 & 21, so if your client doesn't specify any other this would be enough. – Jimbot Jan 7 '18 at 10:42
  • Program Level is enough, unless you have very many programs that need ftp access (which is unlikely). – harrymc Jan 7 '18 at 19:01
  • It sounds odd that you'd need an outbound rule on an OS for it to be allowed to access an FTP server unless you are explicitly blocking that sort of traffic. What's the IP address of the machine that can access the FTP server and what's the IP address of the Server 2012 R2 that cannot access the FTP server? Perhaps you allow a specific subnet range to connect to the listening FTP server and the other Server 2012 R2 machine is not on the same subnet or from a public or non-trusted network range and you need to allow traffic from it to be allowed to connect to the Server via it's firewall rules. – Pimp Juice IT Jan 7 '18 at 19:36
1
+50

Since you say the machine you cannot connect via FTP with is on a completely different subnet than the FTP Server then a couple things come in mind that could need adjusted to resolve this issue as you describe so check and set either or these or both based on your needs.

  1. From the Scope tab of the Windows Firewall rule be sure to add the additional subnet into the Remote IP address section to the These IP addresses list to tell it to also allow from these remote subnets (or IP addresses).

    Please note if you expect any machine to be able to connect to this machine from the outside world or other subnets then having the Any IP address option checked here may be appropriate here as well.

    enter image description here

  2. From the Advanced tab of the Windows Firewall rule be sure to select the appropriate network Profile which is assigned to the applicable network adapter for the network card(s) which you want the FTP service to listen on for connections.

    enter image description here


Further Resources

All still applicable to Windows Server 2012 R2

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.