26

I'm using IntelliJ in Windows and Ctrl-Alt-M is a shortcut that is very useful but right now it's doing nothing. The shortcuts just don't reach IntelliJ. My suspicion is that some other app registered it as a global shortcut or something like that.

In IntelliJ, it seems correctly set:

enter image description here

and if I add another shortcut to "Method...", such as ctrl-alt-shift-r, I can properly use it in the editor in IntelliJ.

I'm running the latest Windows 10 and the latest IntelliJ.

Any ideas how I can find that out?

I followed the process described here:

How can I determine which process owns a hotkey in Windows?

using Visual Studio tool Spy++ and apparently the M-key-down event is never triggering.

This is what happens for ctrl-alt-t:

enter image description here

a shortcut that works as expected in IntelliJ. And this is what happens with ctrl-alt-m:

enter image description here

I have two keyboards connected to this computer: a Kinesis Advantage and a Logitech K120. They both behave the same way in regards to ctrl-alt-m.

  • Does it do anything when IntelliJ is not in focus? – BoffinBrain Jan 5 '18 at 17:33
  • @BoffinbraiN: nope. – pupeno Jan 7 '18 at 11:30
  • @DavidPostill: I added some more information that renders this question, I believe, no longer a duplicate. – pupeno Jan 7 '18 at 19:10
  • Apparently Windows does not send a scan-code for it, so you can't see it in VS Spy. Why don't you map Ctrl-Alt-M to another shortcut that works (and is easier to type)? The keyboard mapping used to be under menu File / Settings / Keymap. – harrymc Jan 9 '18 at 14:38
  • @harrymc: I'm used to ctrl-alt-m and it's the default for creating a new method on IntelliJ, so, if I'm pairing with somebody else, I can do it on their machine and they can do it on my machine as well. – pupeno Jan 9 '18 at 14:39
29

I had the same problem. Turns out NVidia's shadow play catches this shortcut by default as stated here. Apparently all the JetBrains products react the same way. So this will fix the same experience in Android Studio, Rider, CLion, and so on ...

Just follow the steps below.

  1. Open GeForce Experience settings

    Open GeForce Experience settings

  2. Open in-game overlay settings

  3. Open shortcut settings

    Open shortcut settings

  4. Replace the microphone mute shortcut

    Replace the microfone mute shortcut

  5. Enjoy!

  • 7
    Solved the problem for me. You're a lifesaver! – Joffrey Feb 12 '18 at 20:02
  • Thanks. Same issue with visual studio for the unity documentation shortcut. Now if I could figure out how to just unbind instead of replace it ... update: it's backspace – Daniel B. May 25 '18 at 5:23
  • @DanielB. I didn't quite unterstand it. You experience a similar issue in unity engine where a shortcut is captured by visual studio? – TeddybearCrisis Jun 3 '18 at 8:40
  • same goes for the shortcut ALT+F7 for "find code usage". As seen in the last screenshot above it is caught by Pause/resume broadcasting. So basically I removed all NVIDIA shortcuts. – TeddybearCrisis Aug 8 '18 at 12:39
  • In my case I have no NVidia. You can select a text in IDE and check other hotkeys like Alt + F1, Alt + F8. If they work, NVidia doesn't capture hotkeys. – CoolMind May 24 '19 at 9:39
2
+125

I have access to IntelliJ IDEA 10.5.4, so I tested the shortcut on a JavaScript file, and it worked perfectly well when a viable piece of code is selected. The problem seems local to your computer, although you are surely using another version than my old one.

What I can suggest :

  • The Microsoft article Windows keyboard shortcuts for accessibility shows that this shortcut is used by the Magnifier. You may disable the Magnifier, if it is enabled.

  • Check that the shortcut is well defined in your IntelliJ version. In mine this is located under menu File / Settings / Keymap, and I used the keyboard filter to isolate it :

IntelliJ IDEA Keymap for Ctrl+Alt+M

  • Check further by adding another keyboard shortcut to this item and seeing if the new one works.

  • Check even further by Booting Windows in Safe Mode. If the problem disappears then this shortcut is indeed blocked by some third-party product. You could use autoruns to turn startup products off in bunches and booting, until the product is found, finally turning them back on.

  • If you cannot absolutely find why this is happening, I suggest a solution using AutoHotkey, involving the mapping in IntelliJ IDEA of Ctrl-Alt-M to another shortcut, then using AutoHotkey to map Ctrl-Alt-M to the new shortcut.

  • 1
    Thanks @harrymc. Addressing some of your points: I'm not using the magnifier glass. I checked the config and there doesn't seem to be a way to disable shortcuts, only to turn off magnifying glass, which it is. I updated the question regarding IntelliJ's config. – pupeno Jan 10 '18 at 12:00
  • 1
    Magnifier is probably not involved, but see this article. – harrymc Jan 10 '18 at 12:08
  • And what happens when booting in Safe Mode? – harrymc Jan 11 '18 at 7:05
  • in safe mode IntelliJ doesn't start, so, I couldn't test it. – pupeno Jan 13 '18 at 10:10
  • Weird. Maybe you could try Safe Mode with Network. – harrymc Jan 13 '18 at 10:45
1

The following similar question may help: How can I determine which process owns a hotkey in Windows? There is an answer for Windows 10 in there.

Additionally, in this question, the user finds that Ctrl+M was being intercepted by the Bing toolbar. Not sure if Ctrl+M works for you, but it's something to investigate.

  • In Firefox Ctrl + M minimizes current window. If it works there, then Bing toolbar has nothing to do with it. – CoolMind May 24 '19 at 9:41
0

navigate to https://docs.microsoft.com/en-us/sysinternals/

download process monitor and run it

see if anything becomes active when you press Ctrl-Alt-M

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.